Offline: throbber and progress meter shouldn't engage in download situations

RESOLVED WORKSFORME

Status

MailNews Core
Backend
P3
normal
RESOLVED WORKSFORME
18 years ago
10 years ago

People

(Reporter: laurel, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Using jun21 m17 commercial build

When in the offline state, the throbber and progress meter currently engage when
selecting an IMAP or NNTP message.  There is never any alert or timeout and Stop
doesn't halt the animation.  

There are other areas, too, which engage the throbber and progress meter when in
the offline state. One such area is the subscribe dialog for IMAP servers or
when accessing news servers when needing to get/refresh newsgroup lists.  I'm
sure Search Messages will be another area.

1.  Launch to mail, open IMAP inbox.
2.  Go to browser (since we currently have no offline ui items in mail window). 
Click the offline icon so that it is broken/offline.
2.  Go to mail window, try to select an IMAP message which you haven't
downloaded. 

Result:  Throbber and download barber pole progress meter engage. They shouldn't
when in offline state.
(Reporter)

Updated

18 years ago
QA Contact: lchiang → laurel
(Assignee)

Comment 1

18 years ago
I'm a bit confused by this because we have no offline support in messenger.

So we're trying to connect to a server we can't reach. Hence the spinning throbber.

Target Milestone: --- → M19

Comment 2

18 years ago
Oh.  We can't tell that we are offline and not even try to connect at all?

Comment 3

18 years ago
Yes, we can tell if we're offline and not do this. There's a seperate bug,
assigned to scottip, I think, to display text in the message area that says
something like "you are offline so you can't display messages" or something like
that. This bug is in some sense a dup of that bug.
This bug is way old. I have tested this on win2000 and it seem fixed. 

Should we mark it as such ?
I'm closing this bug. There has been no response to my question and both issues
appear fixed.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.