some systems install python 2.3 and do not have 2.5 installed. Since 2.5 is required, we should do a simple test in client.py and notify the developer that a newer version is required.
Created attachment 321274 [details] [diff] [review] adds a check for python 2.5 note that we had to put the test for the version in between the imports because I am not sure that OptionParser is available in older versions of python.
Attachment #321274 - Flags: review?
Attachment #321274 - Flags: review? → review?(ted.mielczarek)
FWIW: 14.3 optparse -- More powerful command line option parser New in version 2.3.
Do we really require Python 2.5? I was pretty sure we'd been avoiding that dependency. What exactly requires it?
@ben - cool; thanks. We probably should continue to keep the test very high for the poor developer that somehow screwed up and has a 2.2 install.
Comment on attachment 321274 [details] [diff] [review] adds a check for python 2.5 AFAIK we don't require Python 2.5 yet, so if there are instances where we do, those are bugs.
Attachment #321274 - Flags: review?(ted.mielczarek) → review-
.py is not needed any longer.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
We still require python 2.3 for the build system (preprocessor.py and others).
You need to log in before you can comment on or make changes to this bug.