Closed Bug 434065 Opened 13 years ago Closed 13 years ago

Bouncer sometimes returns a 404

Categories

(mozilla.org Graveyard :: Server Operations, task)

task
Not set
blocker

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: nthomas, Assigned: oremj)

References

Details

In testing updates for 3.0rc1 on the releasetest channel, QA is finding that sometimes they fail.

An example URL is 
  http://download.mozilla.org/?product=firefox-3.0rc1-complete&os=linux&lang=en-US

If I |curl -IL| that I sometimes get 
  nrthomas@mobi-mandala ~ $ curl -IL "http://download.mozilla.org/?product=firefox-3.0rc1-complete&os=linux&lang=en-US"
  HTTP/1.1 404 Not Found
  Date: Fri, 16 May 2008 17:15:23 GMT
  Server: Apache/2.2.3 (Red Hat)
  Set-Cookie: dmo=10.2.81.4.1210958123835435; path=/; expires=Sat, 16-May-09  17:15:23 GMT
  X-Powered-By: PHP/5.1.6
  Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0, private
  Pragma: no-cache
  Content-Type: text/html; charset=UTF-8

instead of something like 
  nrthomas@mobi-mandala ~ $ curl -IL "http://download.mozilla.org/?product=firefox-3.0rc1-complete&os=linux&lang=en-US"
  HTTP/1.1 302 Found
  Date: Fri, 16 May 2008 17:15:46 GMT
  Server: Apache/2.2.3 (Red Hat)
  Set-Cookie: dmo=10.2.81.4.1210958146586169; path=/; expires=Sat, 16-May-09 17:15:46 GMT
  X-Powered-By: PHP/5.1.6
  Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0, private
  Pragma: no-cache
  Location: http://chuangtzu.acc.umu.se/pub/mozilla.org/firefox/releases/3.0rc1/update/linux-i686/en-US/firefox-3.0rc1.complete.mar
Content-Type: text/html; charset=UTF-8

  HTTP/1.1 200 OK
  Date: Fri, 16 May 2008 17:15:46 GMT
  Server: Apache/2.2.6 (Unix)
  Last-Modified: Tue, 13 May 2008 18:19:56 GMT
  ETag: "110181a-8bba4e-b6158b00"
  Accept-Ranges: bytes
  Content-Length: 9157198
  Content-Type: application/octet-stream

ie get a 404 instead of a 302 to a mirror. Could this be fallout from the db move last night ? Getting a 404 has a bad affect on the updater, as it doesn't handle the error properly and ends up in a confused state.
Assignee: server-ops → oremj
(from irc) oremj says that one of the slave databases for bouncer hadn't been replicating from its master. It's syncing up now, ETA an hour or so.
Added dependency, as nick says on irc this is blocking testing.
Blocks: 428074
What happens if someone testing hits this 404? If they retry, do they get redirected differently, and get successful update?
It just sits there trying to update forever.

I'm getting this over and over on Linux. Every now and then, I can get an update.
This repros on windows and mac also.  Can we get an ETA when this will be fixed?  it's been over the hour mark.
Any update? Talking to QA on irc, they are still hitting this now at 1pm.
Replication is caught up and I can't reproduce the problem anymore.  I'm out to lunch now, but would you check in with Mark if it is still a problem.
Mark is looking at it, and talking with QA on irc. QA was still having problems a few mins ago (13.05). They are retrying to see if its still a problem.
This is fixed now.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Verified.  normal speeds now.
Status: RESOLVED → VERIFIED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.