After computer wakes up from sleep, Firefox sometimes doesn't respond

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: Gareth Marshall, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-02-01])

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

I put my iMac to sleep when I go to bed at night by pressing the power button. When I return to it in the morning, Firefox is no longer responsive, even after waiting about 5 minutes while I get my tea. The only way to get it to work again, as far as I can tell, is to force quit it and then restart Firefox.

The pages I had open last night when I went to be were:
1. http://common-lisp.net/project/cello/
2. http://common-lisp.net/project/cells/

I also use gmail and would have had it open at some point in my session last night. I know in the past I've had problems with gmail causing problems in Firefox - so perhaps it's the guilty party in this case? I'd also been playing games on Kongregate - which would mean that Flash had been running.

Reproducible: Sometimes

Steps to Reproduce:
1. Open Firefox
2. Use Firefox
3. Press the power button on your iMac to send it to sleep
4. Go to bed
5. Press a key on the keyboard to wake the computer up again
6. Go off and have a cup of tea

Actual Results:  
When you move your cursor over the Firefox window and click on it, it remains a beachball. The menu bar still says Finder, but clicking on it does nothing, so it must be under Firefox's control at this point.

Expected Results:  
Perhaps even before I go for my tea, Firefox should be bright and sparky, ready for a new day of using the web.

I have attached the Apple debug information I was given after the force quit.
(Reporter)

Comment 1

10 years ago
Created attachment 321342 [details]
Error details from OS X

Comment 2

10 years ago
It seems that you're stuck in the CoreAudio library, still trying to stop your audio output device.

Comment 3

8 years ago
(In reply to comment #2)
> It seems that you're stuck in the CoreAudio library, still trying to stop your
> audio output device.

Gareth, still see this problem?
Whiteboard: [closeme 2010-02-01]
(Reporter)

Comment 4

8 years ago
No. It seems to be working now.
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.