Vertical bar used as separators of mfenced are not well displayed

RESOLVED WORKSFORME

Status

()

Core
MathML
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: fredw, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1.14) Gecko/20080404 Iceweasel/2.0.0.14 (Debian-2.0.0.14-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1.14) Gecko/20080404 Iceweasel/2.0.0.14 (Debian-2.0.0.14-2)

Firefox displays <mfenced separators="|">...</mfence> by replacing
the separators "|" by clubs "♣".

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

10 years ago
Created attachment 321359 [details]
Testcase
(Reporter)

Comment 2

10 years ago
Created attachment 321360 [details]
Screenshot (Firefox)
(Reporter)

Comment 3

10 years ago
Created attachment 321361 [details]
Screenshot (Amaya 10)
(Reporter)

Comment 4

10 years ago
Created attachment 321364 [details]
Another example without mfenced

Actually, it seems it is not related to mfenced.
This example shows formulae that use two different characters for "|". Only one is well-rendered.

Updated

10 years ago
Component: General → MathML
Product: Firefox → Core
QA Contact: general → mathml
Version: unspecified → Trunk
Can you provide the output of "fc-match --sort Symbol | head -n 5",
and "grep -iw symbol /usr/lib/iceweasel/res/fonts/fontEncoding.properties" please?
(Reporter)

Comment 6

10 years ago
fred@debian:~$ fc-match --sort Symbol | head -n 5
s050000l.pfb: "Standard Symbols L" "Regular"
Vera.ttf: "Bitstream Vera Sans" "Roman"
DejaVuSans.ttf: "DejaVu Sans" "Book"
DejaVuSans-ExtraLight.ttf: "DejaVu Sans" "ExtraLight"
DejaVuSans-Bold.ttf: "DejaVu Sans" "Bold"

fred@debian:~$ grep -iw symbol /usr/lib/iceweasel/res/fonts/fontEncoding.properties
# If you have Symbol (Adobe) type 1 font, keep the following lines 
# commented out (you do NOT need them). However,  with  truetype Symbol 
# Symbol font
encoding.symbol.ttf = Adobe-Symbol-Encoding
encoding.symbol.ftcmap = mac_roman
# TeX's Computer Modern fonts (Roman, Math Italic, Symbol and Extension)

Note: I haven't got the problem with Iceweasel, but with the CVS version of Firefox.
(In reply to comment #6)
> fred@debian:~$ fc-match --sort Symbol | head -n 5
> s050000l.pfb: "Standard Symbols L" "Regular"
> Vera.ttf: "Bitstream Vera Sans" "Roman"
> 
> fred@debian:~$ grep -iw symbol
> /usr/lib/iceweasel/res/fonts/fontEncoding.properties
> # If you have Symbol (Adobe) type 1 font, keep the following lines 
> # commented out (you do NOT need them). However,  with  truetype Symbol 
> # Symbol font
> encoding.symbol.ttf = Adobe-Symbol-Encoding
> encoding.symbol.ftcmap = mac_roman
> # TeX's Computer Modern fonts (Roman, Math Italic, Symbol and Extension)

Thanks for this.  Some lines have been uncommented here, but given you don't have a "Symbol" font, that won't be the problem.

> Note: I haven't got the problem with Iceweasel, but with the CVS version of
> Firefox.

(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1.14)
> Gecko/20080404 Iceweasel/2.0.0.14 (Debian-2.0.0.14-2)
> Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1.14)
> Gecko/20080404 Iceweasel/2.0.0.14 (Debian-2.0.0.14-2)

The cvs 1.8.1 branch version?  Or does bugzilla insert these and are they unrelated to the version where you see the problem?

Try resetting font.mathfont-family to the default, if that has been set.
> Try resetting font.mathfont-family to the default

(in "about:config")
(Reporter)

Comment 9

10 years ago
The version I used for the test is "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008050412 Minefield/3.0pre" but I reported the bug with Iceweasel.

This bug disappears when I set the font.mathfont-family string to use STIX fonts so you may ignore it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 10

10 years ago
Hmm. It seems as if there wasn't anything checked into the browser code to fix this.  (So nothing was broken.) It looks like a configuration issue.

-> WORKSFORME
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.