If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add bookmark box - can't expand folder tree with keyboard

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: Luke Boyling, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

When adding a bookmark using the Add Bookmark screen, you can expand the folder tree using the mouse. However you can't expand or collapse folders using the left and right buttons on the keyboard. This makes it a pain when adding bookmarks using the keyboard shortcut, because I can't file it properly using just the keyboard.

Reproducible: Always

Steps to Reproduce:
1. Bookmarks -> Add bookmark, or Ctrl + D
2. Navigate to the folder tree using Tab
Actual Results:  
Can't expand the folder.

Expected Results:  
Should be able to expand folder using the left and right arrow keys
works for me with Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9pre) Gecko/2008051806 Minefield/3.0pre ID:2008051806, can you retest with the Firefox 3 RC1 ? 
Component: Bookmarks → Places
QA Contact: bookmarks → places
Version: unspecified → 3.0 Branch

Comment 2

10 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008051406 Minefield/3.0pre
(Reporter)

Comment 3

10 years ago
That's odd. It seems to be working now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.