Problem downloading a file with a filename bigger than 20 chars (greek folder problem)

VERIFIED DUPLICATE of bug 430566

Status

()

Toolkit
Downloads API
--
major
VERIFIED DUPLICATE of bug 430566
10 years ago
10 years ago

People

(Reporter: Thanasis, Unassigned)

Tracking

1.9.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; el; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; el; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

Well, if i try to download a file with a filename(without extention - 4 chars(.xxx)) of more than 20 chars to a folder which name (or path contains a folder) named with 20 (or more) greek characters (it may include space but not numbers or other english chars) the file won't download and download manager message is "Blocked: file may contain virus or spyware". This won't happen if change filename's name to be smaller than 21 chars or either the folder...If folder name is far bigger than 20 chars(greek) you can't save it even though using 1 char as the filename...

Reproducible: Always

Steps to Reproduce:
1.download with firefox a file which name (without extention) is 21 chars or more 
2.save it to a folder named with 20 or more greek chars 

   (example: "οοοοοοοοοοοοοοοοοοο")


Actual Results:  
That's it!!! 

File won't download and download manager says:
 "Blocked: file may contain virus or spyware"


Expected Results:  
Should download the file without problems!!!

theme: Firefox (default) 2.0

about:buildconfig

Build platform
target
i686-pc-mingw32

Build tools
Compiler 	Version 	Compiler flags
cl 	14.00.50727.762 	-GL -wd4624 -wd4952 -TC -nologo -W3 -Gy -Fd$(PDBFILE)
cl 	14.00.50727.762 	-GR- -GL -wd4624 -wd4952 -TP -nologo -Zc:wchar_t- -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=beta --enable-optimize --disable-debug --disable-tests --enable-update-packaging --enable-official-branding --enable-jemalloc
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 430566
Verified dup
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.