If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

FORM SELECT width/size: truncating default item

VERIFIED INVALID

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED INVALID
18 years ago
13 years ago

People

(Reporter: Stanton McCandlish, Assigned: rods (gone))

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.73 (Macintosh; U; PPC)
BuildID:    2000062108

    The default, pre-selected item in a non-fixed-width SELECT is being 
truncated. This happens regardless how wide you make the window.

Reproducible: Always
Steps to Reproduce:
1. Load provided URL.
2. Look at (don't click on) the "Browse" SELECT drop down.
3. Notice that the default, pre-selected item text, "CHOOSE FROM MENU" is 
truncated, almost amusingly, to "CHOOSE FROM MEN".



Actual Results:  FORM SELECT (non-fixed width) default pre-selected item text is 
truncated - SELECT dropdown is  not wide enough.


Expected Results:  Width of a FORM SELECT of non-fixed-width should be as wide 
(within some limits of course) as the text of the widest item in the list of 
SELECT OPTIONs, and certainly at least as wide as the default, pre-selected, item 
text, if there is a pre-selected default item.

Comment 1

18 years ago
URL specified gives a 404.
(Reporter)

Comment 2

18 years ago
> URL specified gives a 404.

Woops! Sorry about that.  It's been fixed.

Comment 3

18 years ago
I cannot validate with 20000623. This bug appears to have been FIXED or is
WORKSFORME. Have you changed the URL between when you put it up and now?
(Reporter)

Comment 4

18 years ago
No, no changes.

I'll get a new build early next week and give it a shot.

Comment 5

18 years ago
Changed status to invalid as this bug does not seem to exist.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

18 years ago
Whatever the problem was, it is now gone (under build 2000062914).

Updated

17 years ago
Status: RESOLVED → VERIFIED

Comment 7

17 years ago
Marking verified. Build id 2000082108 OS9. This should really be 
worksforme, I made a mistake way back then and marked invalid.

Updated

13 years ago
OS: Mac System 9.x
You need to log in before you can comment on or make changes to this bug.