Frequent Freezing (Hang, Very high CPU usage, beach ball) in Firefox

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: Andre-John Mas, Unassigned)

Tracking

({hang, perf, stackwanted})

1.9.0 Branch
PowerPC
Mac OS X
hang, perf, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments, 2 obsolete attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_2; en-us) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.1 Safari/525.18
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9) Gecko/2008051202 Firefox/3.0

I have just upgraded from 3.0 beta 5 to 3.0 RC1 and I am experiencing frequent beach balling (freezing/non-responsiveness). This forces me to force quit the application.

Reproducible: Sometimes

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

10 years ago
Created attachment 321438 [details]
Log from force-quit

I have attached a log generated last time this happened and I force quit the application.
(Reporter)

Comment 2

10 years ago
Created attachment 322369 [details]
Second force-quit log

This has happened to me a few times since. I see CPU usage spike, getting beyond 160% (dual core CPU). In all instance I can only force-quit as Firefox does not seem to recover. 

I don't know whether it is significant but I do see a lot of recursion of 'JS_FloorLog2' in the log.
(Reporter)

Comment 3

10 years ago
Changing to Major, as this is happening too often for my liking.
Severity: normal → major
(Reporter)

Updated

10 years ago
Summary: Frequent Freezing → Frequent Freezing (Hang, CPU usage, beach ball)
(Reporter)

Comment 4

10 years ago
This is still happening with the release version of Firefox. In the report what I am seeing is the following being repeated:

 1 _JS_FloorLog2 + 21627 (in libmozjs.dylib) [0xe2346]
    1 _JS_CallTracer + 478 (in libmozjs.dylib) [0xca3f9]
      1 _JS_FloorLog2 + 21627 (in libmozjs.dylib) [0xe2346]
        1 _JS_CallTracer + 478 (in libmozjs.dylib) [0xca3f9]
          1 _JS_FloorLog2 + 21627 (in libmozjs.dylib) [0xe2346]
            1 _JS_CallTracer + 478 (in libmozjs.dylib) [0xca3f9]
              1 _JS_FloorLog2 + 21627 (in libmozjs.dylib) [0xe2346]
                1 _JS_CallTracer + 478 (in libmozjs.dylib) [0xca3f9]
                  1 _JS_FloorLog2 + 21627 (in libmozjs.dylib) [0xe2346]
                    1 _JS_CallTracer + 478 (in libmozjs.dylib) [0xca3f9]
                      1 _JS_FloorLog2 + 21627 (in libmozjs.dylib) [0xe2346]
                        1 _JS_CallTracer + 478 (in libmozjs.dylib) [0xca3f9]
 
(Reporter)

Updated

10 years ago
Summary: Frequent Freezing (Hang, CPU usage, beach ball) → Frequent Freezing (Hang, Very high CPU usage, beach ball)

Comment 5

10 years ago
I'm getting the same thing.
Looking at activity monitor the mem usage is increasing, increasing, increasing -- right now I see RSIZE @ 167MB, when it kicks in I'll see it climb uncontrollably past 1GB (dep. on how fast I can force-quit.)

I'll attach a force-quit log and a spin control hang log.

Please note that since the app doesn't crash Talkback doesn't kick in -- so I (still) don't know how to refer to a talkback, sorry.

Comment 6

10 years ago
Created attachment 334958 [details]
Apple Crash logs + system Prof -- please delete, sorry for spam.

an apple crash log, several spin ctl logs from various hangs in the same session, and system profile.

Comment 7

10 years ago
Created attachment 334959 [details]
Apple Crash logs + system Prof -- please delete (dupe)

an apple crash log, several spin ctl logs from various hangs in the same session, and system profile.

Comment 8

10 years ago
Created attachment 334960 [details]
Apple Crash logs + system Prof

an apple crash log, several spin ctl logs from various hangs in the same session, and system profile.

Updated

10 years ago
Attachment #334959 - Attachment description: Apple Crash logs + system Prof → Apple Crash logs + system Prof -- please delete (dupe)

Updated

10 years ago
Attachment #334958 - Attachment description: Apple Crash logs + system Prof → Apple Crash logs + system Prof -- please delete, sorry for spam.

Comment 9

10 years ago
Shoot, sorry about the multiple attachment spam.  My browser was, ha ha,
undergoing this selfsame crash and I didn't know they went through.

I got the following when it finally crashed out:
  [Exception... "'[JavaScript Error: "script stack space quota is exhausted"
{file:
"file:///Applications/Network/Firefox.app/Contents/MacOS/modules/JSON.jsm"
line: 176}]' when calling method: [nsISessionStore::getBrowserState]" 
nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location:
"JS frame :: chrome://sessionmanager/content/sessionmanager.js :: anonymous ::
line 1919"  data: yes]

I'm attaching the corresponding sessionstore.js, which is humunguous.  I don't
know if that's because the SessionManager is causing the crash, or whether it's
humungous because it's saving the runaway memory pool.

Comment 10

10 years ago
Created attachment 334961 [details]
sessionstore.js from a runaway hang that managed to crash

[Exception... "'[JavaScript Error: "script stack space quota is exhausted" {file: "file:///Applications/Network/Firefox.app/Contents/MacOS/modules/JSON.jsm" line: 176}]' when calling method: [nsISessionStore::getBrowserState]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://sessionmanager/content/sessionmanager.js :: anonymous :: line 1919"  data: yes]
Attachment #334958 - Attachment is obsolete: true
Attachment #334959 - Attachment is obsolete: true

Comment 11

10 years ago
Consider adding 
  keywords: memory, stack, beachball, OSX, FloorLog2, CallTracer, _JS_CallTracer, JS_FloorLog2, libmozjs.dylib, sessionstore, session manager, runaway
  version 3.x branch


(I would add these but I'm either not allowed to or not smart enough -- please ping me directly if it's the latter.)
(Reporter)

Updated

10 years ago
Duplicate of this bug: 467314
(Reporter)

Comment 13

10 years ago
Is there anything particular about the JS_FloorLog2 that could cause it to recurse so deeply?
I have just experienced a crash that seems to have similar recursion (FF 3.0.11). Attaching a log from "problem details".
Created attachment 382963 [details]
crash report with stack trace

Comment 16

9 years ago
(In reply to comment #15)
> Created an attachment (id=382963) [details]
> crash report with stack trace

unfortunately lacks symbols
Severity: major → critical
Keywords: stackwanted
@Wayne Mery

Which symbols are you talking about?

Updated

9 years ago
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → 1.9.0 Branch

Comment 18

9 years ago
Juriy in comment #17
> Which symbols are you talking about?

https://developer.mozilla.org/en/Using_the_Mozilla_symbol_server
Summary: Frequent Freezing (Hang, Very high CPU usage, beach ball) → Frequent Freezing (Hang, Very high CPU usage, beach ball) in Firefox

Comment 19

8 years ago
Is this issue still reproducible?
(Reporter)

Comment 20

8 years ago
I am using 3.6.3 on MacOS X 10.6.3 and I haven't experienced it in a while.

Comment 21

8 years ago
WFM per reporter
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Keywords: hang, perf
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.