If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash in GlobalWindowImpl::Focus

VERIFIED FIXED

Status

()

Core
DOM: Core & HTML
P3
critical
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Ralph Loader, Assigned: saari (gone))

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
This is typical of a crash that happens to me quite often, usually (a) either
with a (very) slow network connection or an overloaded (swapping) machine, (b)
multiple windows open.

Attached: (a) stack trace, (b) debugger print out of *this in top level frame. 
Note that mDocShell == 0.

Not sure that this report will be very useful, but I can probably obtain a
similar crash if more info is needed.

#0  GlobalWindowImpl::Focus (this=0x8b6c8d0) at
../../../../dom/src/base/nsGlobalWindow.cpp:1353
#1  0x40b25975 in nsEventStateManager::PreHandleEvent (this=0x8adc838,
aPresContext=0x8918b90, aEvent=0xbfffe9b4, aTargetFrame=0x8ada604,
aStatus=0xbfffe924, aView=0x8982950) at
../../../../layout/events/src/nsEventStateManager.cpp:465
#2  0x40b6454b in PresShell::HandleEventInternal (this=0x8982490,
aEvent=0xbfffe9b4, aView=0x8982950, aStatus=0xbfffe924) at
../../../../../layout/html/base/src/nsPresShell.cpp:3723
#3  0x40b6444a in PresShell::HandleEvent (this=0x8982490, aView=0x8982950,
aEvent=0xbfffe9b4, aEventStatus=0xbfffe924, aHandled=@0xbfffe8b0) at
../../../../../layout/html/base/src/nsPresShell.cpp:3664
#4  0x4113c7f7 in nsView::HandleEvent (this=0x8982950, event=0xbfffe9b4,
aEventFlags=28, aStatus=0xbfffe924, aHandled=@0xbfffe8b0) at
../../../view/src/nsView.cpp:769
#5  0x4114b70a in nsViewManager2::DispatchEvent (this=0x89bcbd8,
aEvent=0xbfffe9b4, aStatus=0xbfffe924) at
../../../view/src/nsViewManager2.cpp:1385
#6  0x4113b445 in HandleEvent (aEvent=0xbfffe9b4) at
../../../view/src/nsView.cpp:68
#7  0x405c09c6 in nsWidget::DispatchEvent (this=0x89dedb8, aEvent=0xbfffe9b4,
aStatus=@0xbfffe970) at ../../../../widget/src/gtk/nsWidget.cpp:1461
#8  0x405c08d8 in nsWidget::DispatchWindowEvent (this=0x89dedb8,
event=0xbfffe9b4) at ../../../../widget/src/gtk/nsWidget.cpp:1352
#9  0x405c095a in nsWidget::DispatchFocus (this=0x89dedb8, aEvent=@0xbfffe9b4)
at ../../../../widget/src/gtk/nsWidget.cpp:1374
#10 0x405c5988 in nsWindow::SetFocus (this=0x89dedb8) at
../../../../widget/src/gtk/nsWindow.cpp:1052
#11 0x403a87ef in GlobalWindowImpl::Focus (this=0x88f1d30) at
../../../../dom/src/base/nsGlobalWindow.cpp:1365
#12 0x4035bf30 in nsWebShellWindow::HandleEvent (aEvent=0xbfffeb20) at
../../../../xpfe/appshell/src/nsWebShellWindow.cpp:529
#13 0x405c09c6 in nsWidget::DispatchEvent (this=0x86e3878, aEvent=0xbfffeb20,
aStatus=@0xbfffeb1c) at ../../../../widget/src/gtk/nsWidget.cpp:1461
#14 0x405c8275 in handle_mozarea_focus_in (aWidget=0x8999958,
aGdkFocusEvent=0xbfffef00, aData=0x86e3878) at
../../../../widget/src/gtk/nsWindow.cpp:2745
#15 0x4067da5a in gtk_marshal_BOOL__POINTER (object=0x8999958, func=0x405c81f0
<handle_mozarea_focus_in(_GtkWidget *, _GdkEventFocus *, void *)>,
func_data=0x86e3878, args=0xbfffec34) at gtkmarshal.c:28
#16 0x406ac955 in gtk_handlers_run (handlers=0x81a6c30, signal=0xbfffebe8,
object=0x8999958, params=0xbfffec34, after=0) at gtksignal.c:1917
#17 0x406abd7d in gtk_signal_real_emit (object=0x8999958, signal_id=31,
params=0xbfffec34) at gtksignal.c:1477
#18 0x406a9e1c in gtk_signal_emit (object=0x8999958, signal_id=31) at
gtksignal.c:552
#19 0x406dff6f in gtk_widget_event (widget=0x8999958, event=0xbfffef00) at
gtkwidget.c:2860
#20 0x406e84fe in gtk_window_real_set_focus (window=0x899a048, focus=0x8999958)
at gtkwindow.c:1499
#21 0x4067dcaf in gtk_marshal_NONE__POINTER (object=0x899a048, func=0x406e82a0
<gtk_window_real_set_focus>, func_data=0x0, args=0xbfffefbc) at gtkmarshal.c:193
#22 0x406abdbb in gtk_signal_real_emit (object=0x899a048, signal_id=63,
params=0xbfffefbc) at gtksignal.c:1492
#23 0x406a9e1c in gtk_signal_emit (object=0x899a048, signal_id=63) at
gtksignal.c:552
#24 0x406e59f8 in gtk_window_set_focus (window=0x899a048, focus=0x8999958) at
gtkwindow.c:441
#25 0x406e09d6 in gtk_widget_real_grab_focus (focus_widget=0x8999958) at
gtkwidget.c:3119
#26 0x4067de7b in gtk_marshal_NONE__NONE (object=0x8999958, func=0x406e0898
<gtk_widget_real_grab_focus>, func_data=0x0, args=0xbffff32c) at
gtkmarshal.c:312
#27 0x406abdbb in gtk_signal_real_emit (object=0x8999958, signal_id=18,
params=0xbffff32c) at gtksignal.c:1492
#28 0x406a9e1c in gtk_signal_emit (object=0x8999958, signal_id=18) at
gtksignal.c:552
#29 0x406e082e in gtk_widget_grab_focus (widget=0x8999958) at gtkwidget.c:3072
#30 0x405c8185 in handle_toplevel_focus_in (aWidget=0x899a048,
aGdkFocusEvent=0x8217620, aData=0x86e3878) at
../../../../widget/src/gtk/nsWindow.cpp:2667
#31 0x4067da5a in gtk_marshal_BOOL__POINTER (object=0x899a048, func=0x405c813c
<handle_toplevel_focus_in(_GtkWidget *, _GdkEventFocus *, void *)>,
func_data=0x86e3878, args=0xbffff6d4) at gtkmarshal.c:28
#32 0x406ac955 in gtk_handlers_run (handlers=0x81a6c90, signal=0xbffff688,
object=0x899a048, params=0xbffff6d4, after=0) at gtksignal.c:1917
#33 0x406abd7d in gtk_signal_real_emit (object=0x899a048, signal_id=31,
params=0xbffff6d4) at gtksignal.c:1477
#34 0x406a9e1c in gtk_signal_emit (object=0x899a048, signal_id=31) at
gtksignal.c:552
#35 0x406dff6f in gtk_widget_event (widget=0x899a048, event=0x8217620) at
gtkwidget.c:2860
#36 0x4067cc1a in gtk_main_do_event (event=0x8217620) at gtkmain.c:786
#37 0x405bb54d in handle_gdk_event (event=0x8217620, data=0x0) at
../../../../widget/src/gtk/nsGtkEventHandler.cpp:902
#38 0x40729111 in gdk_event_dispatch (source_data=0x0, current_time=0xbffffa6c,
user_data=0x0) at gdkevents.c:2129
#39 0x40757646 in g_main_dispatch (dispatch_time=0xbffffa6c) at gmain.c:656
#40 0x40757c40 in g_main_iterate (block=1, dispatch=1) at gmain.c:877
#41 0x40757de9 in g_main_run (loop=0x82175b0) at gmain.c:935
#42 0x4067c489 in gtk_main () at gtkmain.c:476
#43 0x405b3582 in nsAppShell::Run (this=0x80f3388) at
../../../../widget/src/gtk/nsAppShell.cpp:334
#44 0x40359c07 in nsAppShellService::Run (this=0x80fc220) at
../../../../xpfe/appshell/src/nsAppShellService.cpp:386
#45 0x0804d393 in main1 (argc=1, argv=0xbffffc64, nativeApp=0x0) at
../../../xpfe/bootstrap/nsAppRunner.cpp:908
#46 0x0804d809 in main (argc=1, argv=0xbffffc64) at
../../../xpfe/bootstrap/nsAppRunner.cpp:1094
#47 0x40223b10 in __libc_start_main () from /usr/lib/libc.so.6


(gdb) print *this

$4 = {<nsIScriptGlobalObject> = {<nsISupports> = {_vptr. =
0x40434320}, <No data fields>}, <nsIDOMWindow> = {<nsISupports> =
{_vptr. = 0x404341a0}, <No data fields>}, <nsIJSScriptObject> =
{<nsIScriptObjectOwner> = {<nsISupports> = {_vptr. = 0x40434160}, <No
data fields>}, <No data fields>}, <nsIScriptObjectPrincipal> =
{<nsISupports> = {_vptr. = 0x40434138}, <No data fields>},
<nsIDOMEventReceiver> = {<nsIDOMEventTarget> = {<nsISupports> =
{_vptr. = 0x40434100}, <No data fields>}, <No data fields>},
<nsPIDOMWindow> = {<nsISupports> = {_vptr. = 0x404340c0}, <No data
fields>}, <nsIDOMViewCSS> = {<nsIDOMAbstractView> = {<nsISupports> =
{_vptr. = 0x404340a0}, <No data fields>}, <No data fields>},
<nsSupportsWeakReference> = {<nsISupportsWeakReference> =
{<nsISupports> = {_vptr. = 0x40434080}, <No data fields>}, mProxy =
0x0}, mRefCnt = 4, mContext = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No
data fields>}, mDocument = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No
data fields>}, mOpener = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No data
fields>}, mControllers = {<nsCOMPtr_base> = {mRawPtr = 0x92f4d98}, <No
data fields>}, mListenerManager = {<nsCOMPtr_base> = {mRawPtr = 0x0},
<No data fields>}, mSidebar = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No
data fields>}, mScriptObject = 0x0, mNavigator = 0x0, mScreen = 0x0,
mHistory = 0x0, mFrames = 0x0, mLocation = 0x92dc348, mMenubar = 0x0,
mToolbar = 0x0, mLocationbar = 0x0, mPersonalbar = 0x0, mStatusbar =
0x0, mScrollbars = 0x0, mTimeouts = 0x0, mTimeoutInsertionPoint = 0x0,
mRunningTimeout = 0x0, mTimeoutPublicIdCounter = 1,
mTimeoutFiringDepth = 0, mFirstDocumentLoad = 0, mStatus =
{<basic_nsAWritableString<short unsigned int>> =
{<basic_nsAReadableString<short unsigned int>> = {_vptr. =
0x400f1ce0}, <No data fields>}, <nsStr> = {mLength = 0, mCapacity = 0,
mCharSize = eTwoByte, mOwnsBuffer = 0, {mStr = 0x400e7974 "", mUStr =
0x400e7974}}, <No data fields>}, mDefaultStatus =
{<basic_nsAWritableString<short unsigned int>> =
{<basic_nsAReadableString<short unsigned int>> = {_vptr. =
0x400f1ce0}, <No data fields>}, <nsStr> = {mLength = 0, mCapacity = 0,
mCharSize = eTwoByte, mOwnsBuffer = 0, {mStr = 0x400e7974 "", mUStr =
0x400e7974}}, <No data fields>}, mGlobalObjectOwner = 0x8b74e1c,
mDocShell = 0x0, mChromeEventHandler = 0x89fc6e4, mCrypto =
{<nsCOMPtr_base> = {mRawPtr = 0x0}, <No data fields>}, mPkcs11 =
{<nsCOMPtr_base> = {mRawPtr = 0x0}, <No data fields>}}

Comment 1

18 years ago
crash in DOM code.  updating component and setting default owner.  Reporter, can
you give us some specific steps to reproduce this crash.
Assignee: asa → jst
Component: Browser-General → DOM Level 0
QA Contact: doronr → desale

Comment 2

18 years ago
adding crash keyword
Keywords: crash
(Reporter)

Comment 3

18 years ago
The crash is intermittent, and not entirely predictable, so I can't really
give exact steps.  But it does happen to me repeatedly under similar circumstances:

(1) I'm browsing over a 56k modem with a download (from another program) in
progress (causing significant network delays).

(2) I have multiple windows open, and am loading multiple pages simultaneously
(3) Switching between mozilla windows and other applications.

If I can pin down circumstances any more, I'll note them here.
(Reporter)

Comment 4

18 years ago
Did some more playing around:
(a) the multiple windows bit is not necessary - can reproduce with just one
window.
(b) some sites are worse than others. Pages on www.trademe.co.nz seem to be
especially good at causing the crash.

Comment 5

18 years ago
Ralph, can you make sure you are still crashing with build 2000062220 or later?
See bug 41116. There was a recent checkin that fixed a crash in PreHandleEvent
caused by a null document.

Comment 6

18 years ago
I'm seeing this too on the 2000-06-23-14-M17 nightly build. My favourite site
for provoking the problem is http://www.itv-f1.com. It works fine so long as I
don't change windows, but if I switch virtual desktops while the page is loading
I'm pretty much guaranteed a crash. The M16 release is similarly crashable.

I'm using Enlightenment for virtual desktops and XFree86 4.0. My connection is a
slow dialup, 48Kbps at most.
(Reporter)

Comment 7

18 years ago
Using a build from CVS, 26 Jun.

Can still reproduce crash easily.

(1) Set my GUI environment to focus-follows-mouse (makes it easy &
quick to change window focus).

(2) Connect to internet over 56k modem.  Start large ftp transfer in
background, causing other network operations have a delay of around 10
seconds.

(3) Start mozilla; arrange mozilla window & another window side by side.

(4) Start loading trademe.co.nz.

(5) Continually move mouse between the two windows from step (3),
causing a rapid succession of focus-in and focus-out.

(6) Crash occurs.

Backtrace attached.  It's a bit different to the original, despite occurring
under apparently identical conditions. Note that unlike the trace originally
attached to
the bug report, this is *not* a NULL pointer dereference.  Maybe a
dangling pointer?  Hmmm... going up to frame 2, we have this->mRefCnt
== 0 - is that legal?

(gdb) up
#2  0x40c9b023 in nsHTMLAnchorElement::HandleDOMEvent (this=0x41397b38,
aPresContext=0x889ed78, aEvent=0xbfffe5ec, aDOMEvent=0x0, aFlags=1,
aEventStatus=0xbfffe548) at
../../../../../layout/html/content/src/nsHTMLAnchorElement.cpp:412
(gdb) p this->mRefCnt
$9 = 0
(gdb) 
-------------------------------------

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1024 (runnable)]
0x00000019 in ?? ()
(gdb) bt
#0  0x00000019 in ?? ()
#1  0x40c93b8a in nsGenericHTMLElement::HandleDOMEventForAnchors
(this=0x41397b4c, aOuter=0x41397b44, aPresContext=0x889ed78, aEvent=0xbfffe5ec,
aDOMEvent=0x0, aFlags=1, aEventStatus=0xbfffe548) at
../../../../../layout/html/content/src/nsGenericHTMLElement.cpp:1088
#2  0x40c9b023 in nsHTMLAnchorElement::HandleDOMEvent (this=0x41397b38,
aPresContext=0x889ed78, aEvent=0xbfffe5ec, aDOMEvent=0x0, aFlags=1,
aEventStatus=0xbfffe548) at
../../../../../layout/html/content/src/nsHTMLAnchorElement.cpp:412
#3  0x40c4397d in nsEventStateManager::SendFocusBlur (this=0x8890e20,
aPresContext=0x889ed78, aContent=0x41397b44) at
../../../../layout/events/src/nsEventStateManager.cpp:2409
#4  0x40c42d58 in nsEventStateManager::SetContentState (this=0x8890e20,
aContent=0x41397b44, aState=2) at
../../../../layout/events/src/nsEventStateManager.cpp:2173
#5  0x40c9adb0 in nsHTMLAnchorElement::SetFocus (this=0x41397b38,
aPresContext=0x889ed78) at
../../../../../layout/html/content/src/nsHTMLAnchorElement.cpp:311
#6  0x40c3f0dd in nsEventStateManager::PreHandleEvent (this=0x8644980,
aPresContext=0x816a768, aEvent=0xbfffe9d4, aTargetFrame=0x86426ec,
aStatus=0xbfffe944, aView=0x82f7498) at
../../../../layout/events/src/nsEventStateManager.cpp:470
#7  0x40c7e67b in PresShell::HandleEventInternal (this=0x828b898,
aEvent=0xbfffe9d4, aView=0x82f7498, aStatus=0xbfffe944) at
../../../../../layout/html/base/src/nsPresShell.cpp:3896
#8  0x40c7e57a in PresShell::HandleEvent (this=0x828b898, aView=0x82f7498,
aEvent=0xbfffe9d4, aEventStatus=0xbfffe944, aHandled=@0xbfffe8d0) at
../../../../../layout/html/base/src/nsPresShell.cpp:3837
#9  0x410b87f7 in nsView::HandleEvent (this=0x82f7498, event=0xbfffe9d4,
aEventFlags=28, aStatus=0xbfffe944, aHandled=@0xbfffe8d0) at
../../../view/src/nsView.cpp:769
#10 0x410c771a in nsViewManager2::DispatchEvent (this=0x83039b8,
aEvent=0xbfffe9d4, aStatus=0xbfffe944) at
../../../view/src/nsViewManager2.cpp:1387
#11 0x410b7445 in HandleEvent (aEvent=0xbfffe9d4) at
../../../view/src/nsView.cpp:68
#12 0x405bfac6 in nsWidget::DispatchEvent (this=0x82880b8, aEvent=0xbfffe9d4,
aStatus=@0xbfffe990) at ../../../../widget/src/gtk/nsWidget.cpp:1461
#13 0x405bf9d8 in nsWidget::DispatchWindowEvent (this=0x82880b8,
event=0xbfffe9d4) at ../../../../widget/src/gtk/nsWidget.cpp:1352
#14 0x405bfa5a in nsWidget::DispatchFocus (this=0x82880b8, aEvent=@0xbfffe9d4)
at ../../../../widget/src/gtk/nsWidget.cpp:1374
#15 0x405c4d08 in nsWindow::SetFocus (this=0x82880b8) at
../../../../widget/src/gtk/nsWindow.cpp:1052
#16 0x403a8e7f in GlobalWindowImpl::Focus (this=0x812ac58) at
../../../../dom/src/base/nsGlobalWindow.cpp:1365
#17 0x4035bf30 in nsWebShellWindow::HandleEvent (aEvent=0xbfffeb40) at
../../../../xpfe/appshell/src/nsWebShellWindow.cpp:529
#18 0x405bfac6 in nsWidget::DispatchEvent (this=0x81296e8, aEvent=0xbfffeb40,
aStatus=@0xbfffeb3c) at ../../../../widget/src/gtk/nsWidget.cpp:1461
#19 0x405c75f5 in handle_mozarea_focus_in (aWidget=0x8129548,
aGdkFocusEvent=0xbfffef20, aData=0x81296e8) at
../../../../widget/src/gtk/nsWindow.cpp:2745
#20 0x4067da5a in gtk_marshal_BOOL__POINTER (object=0x8129548, func=0x405c7570
<handle_mozarea_focus_in(_GtkWidget *, _GdkEventFocus *, void *)>,
func_data=0x81296e8, args=0xbfffec54) at gtkmarshal.c:28
#21 0x406ac955 in gtk_handlers_run (handlers=0x8146a78, signal=0xbfffec08,
object=0x8129548, params=0xbfffec54, after=0) at gtksignal.c:1917
#22 0x406abd7d in gtk_signal_real_emit (object=0x8129548, signal_id=31,
params=0xbfffec54) at gtksignal.c:1477
#23 0x406a9e1c in gtk_signal_emit (object=0x8129548, signal_id=31) at
gtksignal.c:552
#24 0x406dff6f in gtk_widget_event (widget=0x8129548, event=0xbfffef20) at
gtkwidget.c:2860
#25 0x406e84fe in gtk_window_real_set_focus (window=0x8129a70, focus=0x8129548)
at gtkwindow.c:1499
#26 0x4067dcaf in gtk_marshal_NONE__POINTER (object=0x8129a70, func=0x406e82a0
<gtk_window_real_set_focus>, func_data=0x0, args=0xbfffefdc) at gtkmarshal.c:193
#27 0x406abdbb in gtk_signal_real_emit (object=0x8129a70, signal_id=63,
params=0xbfffefdc) at gtksignal.c:1492
#28 0x406a9e1c in gtk_signal_emit (object=0x8129a70, signal_id=63) at
gtksignal.c:552
#29 0x406e59f8 in gtk_window_set_focus (window=0x8129a70, focus=0x8129548) at
gtkwindow.c:441
#30 0x406e09d6 in gtk_widget_real_grab_focus (focus_widget=0x8129548) at
gtkwidget.c:3119
#31 0x4067de7b in gtk_marshal_NONE__NONE (object=0x8129548, func=0x406e0898
<gtk_widget_real_grab_focus>, func_data=0x0, args=0xbffff34c) at
gtkmarshal.c:312
#32 0x406abdbb in gtk_signal_real_emit (object=0x8129548, signal_id=18,
params=0xbffff34c) at gtksignal.c:1492
#33 0x406a9e1c in gtk_signal_emit (object=0x8129548, signal_id=18) at
gtksignal.c:552
#34 0x406e082e in gtk_widget_grab_focus (widget=0x8129548) at gtkwidget.c:3072
#35 0x405c7505 in handle_toplevel_focus_in (aWidget=0x8129a70,
aGdkFocusEvent=0x822c7b8, aData=0x81296e8) at
../../../../widget/src/gtk/nsWindow.cpp:2667
#36 0x4067da5a in gtk_marshal_BOOL__POINTER (object=0x8129a70, func=0x405c74bc
<handle_toplevel_focus_in(_GtkWidget *, _GdkEventFocus *, void *)>,
func_data=0x81296e8, args=0xbffff6f4) at gtkmarshal.c:28
#37 0x406ac955 in gtk_handlers_run (handlers=0x8146ad8, signal=0xbffff6a8,
object=0x8129a70, params=0xbffff6f4, after=0) at gtksignal.c:1917
#38 0x406abd7d in gtk_signal_real_emit (object=0x8129a70, signal_id=31,
params=0xbffff6f4) at gtksignal.c:1477
#39 0x406a9e1c in gtk_signal_emit (object=0x8129a70, signal_id=31) at
gtksignal.c:552
#40 0x406dff6f in gtk_widget_event (widget=0x8129a70, event=0x822c7b8) at
gtkwidget.c:2860
#41 0x4067cc1a in gtk_main_do_event (event=0x822c7b8) at gtkmain.c:786
#42 0x405ba64d in handle_gdk_event (event=0x822c7b8, data=0x0) at
../../../../widget/src/gtk/nsGtkEventHandler.cpp:902
#43 0x40729111 in gdk_event_dispatch (source_data=0x0, current_time=0xbffffa8c,
user_data=0x0) at gdkevents.c:2129
#44 0x40757646 in g_main_dispatch (dispatch_time=0xbffffa8c) at gmain.c:656
#45 0x40757c40 in g_main_iterate (block=1, dispatch=1) at gmain.c:877
#46 0x40757de9 in g_main_run (loop=0x822c748) at gmain.c:935
#47 0x4067c489 in gtk_main () at gtkmain.c:476
#48 0x405b2682 in nsAppShell::Run (this=0x8102388) at
../../../../widget/src/gtk/nsAppShell.cpp:334
#49 0x40359c07 in nsAppShellService::Run (this=0x80d41f0) at
../../../../xpfe/appshell/src/nsAppShellService.cpp:386
#50 0x0804d3c3 in main1 (argc=1, argv=0xbffffc84, nativeApp=0x0) at
../../../xpfe/bootstrap/nsAppRunner.cpp:914
#51 0x0804d839 in main (argc=1, argv=0xbffffc84) at
../../../xpfe/bootstrap/nsAppRunner.cpp:1100
#52 0x40223b10 in __libc_start_main () from /usr/lib/libc.so.6
Reassigning to our focus expert, saari.
Assignee: jst → saari
(Assignee)

Comment 9

18 years ago
mDocShell being null is a vaild state, so I just added a null check. Should fix 
the problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 10

18 years ago
I can still crash the 2000-06-29-08-M17 nightly build on the same sites simply
by changing focus. I use Sloppy focus in my wm. Simply switching focus back and
forth to another window on the same desktop while loading pages from these sites
(the news articles on itv-f1.com and the buy/sell pages on trademe.co.nz) will
cause a crash.
(Reporter)

Comment 11

18 years ago
Seeing that this particular crash has been fixed, but a more general problem
exists, I've opened a new buzilla report for it: see 44311

Comment 12

18 years ago
As per reporter, this particular problem's been fixed.
Marking verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.