Send Link function does not work after upgrading from RC1 Error nsIExternalProtocolService.loadUrl ... browser.js :: anonymous :: line 5309 [unix]

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
4 years ago

People

(Reporter: dwgallien, Unassigned)

Tracking

3.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.0) Gecko/2008051400 SUSE/3.0-2.3 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.0) Gecko/2008051400 SUSE/3.0-2.3 Firefox/3.0

Just upgraded from Firefox 3.0 Beta 5 to RC 1 (Although distro is x64, am using 586 32-bit Firefox as SUSE supports).  "Send Link . . . " from File Menu and from Context Menu, no longer works.  Checked about:config value for "network.protocol-handler.app.mailto" and is OK, same as before ("kmailservice"). Tried changing value (to "seamonkey") and also does not work.

Reproducible: Always

Steps to Reproduce:
1.Click on File/Send Link or right-click/Send Link, on any mailable web page
2.
3.
Actual Results:  
No response from browser

Expected Results:  
Open a Kmail Composer (or Seamonkey Composer) window, with the web page url placed in the body of the message

Worked fine in Beta 5
(Reporter)

Comment 1

11 years ago
Problem *not* reproduceable on Windows XP version.
(Reporter)

Comment 2

11 years ago
Problem is resolved by creating a new profile.  When working from a fresh profile, the Send Link function when first used opened a dialog box asking for the mail client to use, showing Yahoo as a default and providing a navigation box to the file system for selection of another executable.  There is a note in the dialog box indicating that this can be modified later in preferences.

It would appear that the prefs.js entry is no longer used, because after adding a mail client in the above dialog box, there was no entry in the file with the name "network.protocol-handler.app.mailto" nor any entry with the mail client value I provided (which subsquently worked).  So apparently the control for Send Link is located elsewhere - I could not find it.

In summary, when RC 1 is installed as an upgrade, the previously specified mail client for Send Link does not get migrated.  Then, unlike when a fresh profile has been created, the first invocation of Send Link does not prompt for a mail client. Finally, I could not locate where/how to update the Send Link client value. 
Severity: major → normal
(Reporter)

Comment 3

11 years ago
The error being logged to the Firefox console when Send Link was not working was:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIExternalProtocolService.loadUrl]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://browser/content/browser.js :: anonymous :: line 5309"  data: no]

Updated

11 years ago
Duplicate of this bug: 441865

Comment 5

10 years ago
Creating new profile does not help.

The "Send Link" button still does not work in FF3.0 on most of the Linux platforms I tested.


Comment 6

10 years ago
This is happening as well on Gentoo Linux, very annoying.

Comment 7

10 years ago
Problem is present in the contributed Solaris 10 SPARC build of FF 3.0.1, but the following error is generated by attempting the action:

ld.so.1: evolution-1.4: fatal: relocation error: file /net/sol10.local/bin/firefox-3.0.1/depend/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-gif.so: symbol g_intern_static_string: referenced symbol not found

This is despite the mailto action in the Applications tab of the Preferences dialog being set to "Use thunderbird (default)".

Comment 8

10 years ago
Interesting...

I have upgraded my system from Fedora 7 to Fedora 9 and imported my FF3 and Thunderbird profiles to the new system.

The "Send Link" button now works (it opens Thunderbird) !

Comment 9

10 years ago
Try exiting firefox and deleting mimeTypes.rdf then let firefox recreate it.
More info in http://bugzilla.mozilla.org/show_bug.cgi?id=446481

Comment 10

10 years ago
(In reply to comment #9)
> Try exiting firefox and deleting mimeTypes.rdf then let firefox recreate it.
> More info in http://bugzilla.mozilla.org/show_bug.cgi?id=446481
> 

Just tried this, no luck...

Comment 11

10 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008122616 Gentoo Firefox/3.0.5

Neither my "Send Link" nor clicking on "mailto:" links is currently working, and it hasn't worked since I upgraded to Firefox 3. In fact, I ended up downgrading to Firefox 2 for a time because this was so frustrating.

So many people are experiencing this problem. If it's a bug, why hasn't it been fixed, and if it's not a bug, shouldn't there be an FAQ or Knowledge Base topic on it?

Comment 12

10 years ago
(In reply to comment #11)
> Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008122616 Gentoo
> Firefox/3.0.5
> 
> Neither my "Send Link" nor clicking on "mailto:" links is currently working,
> and it hasn't worked since I upgraded to Firefox 3. In fact, I ended up
> downgrading to Firefox 2 for a time because this was so frustrating.
> 
> So many people are experiencing this problem. If it's a bug, why hasn't it been
> fixed, and if it's not a bug, shouldn't there be an FAQ or Knowledge Base topic
> on it?

Never mind. I found the updated instructions for specifying external applications here: http://support.mozilla.com/en-US/kb/Changing+the+e-mail+program+used+by+Firefox

...and unlike several versions ago, it now works :)

Thanks.
Severity: normal → minor
Summary: Send Link function is broken in Firefox 3.0 RC 1 → Send Link function does not work
Version: unspecified → 3.0 Branch
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

10 years ago
Severity: minor → normal
Component: General → Shell Integration
QA Contact: general → shell.integration
Summary: Send Link function does not work → Send Link function does not work after upgrading from RC1 Error nsIExternalProtocolService.loadUrl ... browser.js :: anonymous :: line 5309 [unix]

Updated

10 years ago
Duplicate of this bug: 442918
Likely an external protocol handling bug (e.g. nsIExternalProtocolService is the first clue) which is not shell integration... what ever the case the shell integration code path does not come into play so moving back to general for further triage
http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser.js#5657
Component: Shell Integration → General
QA Contact: shell.integration → general

Comment 15

4 years ago
If anyone here still see this please reopen the bug.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.