Dynamically appended inputs break form control state for radio buttons on reload

RESOLVED DUPLICATE of bug 311507

Status

()

Core
General
RESOLVED DUPLICATE of bug 311507
10 years ago
10 years ago

People

(Reporter: Simon Lieschke, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0

The selected radio button in a set of radio buttons is not preserved on a page reload via F5 if one or more form inputs have been dynamically inserted into the page before the radio button set.

Reproducible: Always

Steps to Reproduce:
1. Load testcase1.htm in the browser.
2. Reload the page via F5 three times.
Actual Results:  
After the first reload the Label 3 radio button in Radio Set 2 is selected.
After the second reload the Label 4 radio button in Radio Set 2 is selected.
After the final reload no radio button in Radio Set 2 is selected

Expected Results:  
The Label 2 radio button in Radio Set 2 remains selected.
(Reporter)

Comment 1

10 years ago
Created attachment 321515 [details]
Testcase 1
(Reporter)

Comment 2

10 years ago
Created attachment 321517 [details]
Testcase 2

Note in the second testcase what happens if two inputs are dynamically appended. The selected radio button in Radio Set 2 jumps two places down the set of radio each time the page is reloaded via F5.

Comment 3

10 years ago
I have run in to this problem as well. This can create some data corruption issues if the end users are not vigilant in double checking the data they are submitting in RIAs.

The test cases do a create job at recreating the problem.

FYI, my user agent:
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 311507
You need to log in before you can comment on or make changes to this bug.