Adobe Flash key listeners not working

RESOLVED DUPLICATE of bug 434914

Status

()

Firefox
Extension Compatibility
--
critical
RESOLVED DUPLICATE of bug 434914
10 years ago
10 years ago

People

(Reporter: billy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008051804 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008051804 Minefield/3.0pre

Was working fine in beta, now it doesn't in latest build and in FF3 RC1

http://billychasen.com/test/test.html Is a demo file that works in previous versions.  It's code is simply:

var keyListen:Object=new Object();

keyListen.onKeyUp = function() 
{
	_root.asdf.text = "key pressed!";
}

Key.addListener(keyListen);

btn.onRelease = function()
{
	_root.asdf.text = "button pressed!";
}

Either flash is not receiving the key pressing or the method of embedding flash is causing an error.

The demo URL I created has 2 methods of loading in the same swf.  Both do not work in current version.

Reproducible: Always

Steps to Reproduce:
1.  Go to test url
2.  Click on red area to give flash focus
3.  Press any key -- flash does not receive the key
Actual Results:  
No key returned in flash

Expected Results:  
key returned
(Reporter)

Comment 1

10 years ago
please ignore btn.onRelease call -- that was from earlier testing
(Reporter)

Comment 2

10 years ago
Sorry -- I also have latest flash version installed -- 9,0,124,0

Comment 3

10 years ago
I am having the same issues...

Mac OSX

Key Up events in (at least) Flash Player 9 are no longer firing for a majority of keys.

All keys fire key downs

Control and shift fire key up events

... Possibly linked to recent additions of shortcuts?

Comment 4

10 years ago
I can confirm the same issue. It actually scared me for a second as I was literally in the middle of launching a Flash-based game site (http://playmockingbird.com/) and discovered all of our games/app afflicted by this. I have also found several major games on Kongregate.com as well as AddictingGames.com that are affected.

The only change to my system was the upgrade from Firefox 3 beta (4 or 5, whichever came before RC1) to RC1. I even re-installed Flash Player, upgraded to the latest, switched between release/debug versions... all afflicted the same way (missing key_up events). All other browsers on my system work correctly (as do all of the browsers I tested under WindowsXP).

I've had to switch to using Safari due to this issue... I miss Firefox!
(Reporter)

Comment 5

10 years ago
Now that several people have also confirmed this, I'm putting this to critical.  When you break half the web -- I can't see it as anything but.
Severity: major → critical

Comment 6

10 years ago
I can confirm this bug also with firefox rc1, testing with flash version 9.0.124.0, 9.0.115.0 and  10.0 b218, they all fail.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 434914
You need to log in before you can comment on or make changes to this bug.