Repeating desktop screenshot fragments on page background on amd64

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
10 years ago
7 years ago

People

(Reporter: Marti Raudsepp, Unassigned)

Tracking

3.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-09-15], URL)

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; ; Linux x86_64; rv:1.9) Gecko/2008051800 (Gentoo) Firefox/2.0
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9) Gecko/2008051800 (Gentoo) Firefox/3.0

The page background on www.slskrecords.com has been replaced by a fragment of what's on my screen. Kind of hard to describe, look at the screenshot. This only happens on the 64-bit build; the 32-bit Gentoo binary package (mozilla-firefox-bin) does not exhibit this problem (different library versions?).

Some updates of my screen are also reflected in Firefox; for instance when clicking on the terminal icon, it updates once the terminal window pops up; the launch icon on the toolbar changes to the "mouseover" state. But there are no updates while the button is in the pressed state etc.

Rendering of this page is also very slow; it takes over 1 second (no exaggeration) to switch to this tab on my Athlon 64 3000+, with unaccelerated "nv" drivers.

I have observed a similar effect on another page as well, but I cannot recall where.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.slskrecords.com/
2. Observe the described awkward effect.

Actual Results:  
The background image has been replaced with a screenshot fragment of my desktop.


Expected Results:  
Displayed the correct background.

Cairo version 1.6.4, GTK+ version 2.12.5-r1, X.org 7.3 (X.org server version 1.4.0.90-r3)
Using nvidia's unaccelerated/open source "nv" drivers.

What else is relevant?
(Reporter)

Comment 1

10 years ago
Created attachment 321541 [details]
Screenshot of the result
(Reporter)

Comment 2

10 years ago
Created attachment 322392 [details]
screenshot of www.sixxs.net/main/

I have used Firefox 3.0 on Linux for some time now, and finding web sites that exhibit this bug is not hard at all; I don't mind the rendering problems so much, but it makes given sites *extremely* slow; every single redraw takes the better part of a second.

Attaching another screenshot of http://www.sixxs.net/main/
Reporter, are you still seeing this issue with Firefox 3.6.x or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2010-09-15]
Version: unspecified → 3.0 Branch
(Reporter)

Comment 4

8 years ago
Yeah, that seems to be the typical way of handling bugs by Mozilla. Wait until they're not relevant anymore and then close them.

No, I'm not seeing this issue anymore because I've changed my computer and my OS several times since.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
>Yeah, that seems to be the typical way of handling bugs by Mozilla. Wait until 
>they're not relevant anymore and then close them.

We get every day more than 100 new bug reports and we are unable to process all of them.
It seems that you are the only one with that problem because we would get more reports about the same issue or triager like me failed to dupe the reports and it got probably fixed in a different bug.
BTW: The product Firefox is basically only the User Interface, everything content related is done by the rendering Engine Gecko (product:Core).
You need to log in before you can comment on or make changes to this bug.