bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

blank right pane of preferences in new message/compose

VERIFIED FIXED in M18

Status

MailNews Core
Composition
P1
critical
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: qaz2, Assigned: Jean-Francois Ducarroz)

Tracking

({crash, pp})

Trunk
PowerPC
Mac System 8.6
crash, pp

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+])

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.06 (Macintosh; I; PPC, Nav)
BuildID:    2000061411

When you choose Edit-Preferences from a New Message/Compose window, it will 
appear, and the left pane (where you choose which type of preferences you want 
to edit) works fine.  However, the right pane is totally blank (gray), no matter 
what you choose in the left pane.

Reproducible: Always
Steps to Reproduce:
1.Open Mozilla
2.Choose File-New-New Message
3.When the New Message window loads, choose Edit-Preferences.

Actual Results:  The Preferences dialog appears, but the right pane is 
completely blank, no matter what you choose in the left pane.

Expected Results:  Mozilla should have displayed a normal Preferences dialog.

Comment 1

18 years ago
Same with commercial build jun22.  Launch new message window from mail window
doesn't yet have access to Preferences (always disabled).  Launch new message
from browser does exhibit this problem.

QA Contact: lchiang → laurel

Comment 2

18 years ago
Appears to be available on Mac only.  Linux, NT both don't have the preferences
item available in New Message window, even when launched from browser.
Keywords: pp

Comment 3

18 years ago
Check your prefs.js in your profile and remove the line that says:

    user_pref("nglayout.widget.gfxscrollbars", false);

if it exists. (If it is there, it means you are using native scrollbars;
this is not being maintained -- see, e.g., bug 43434).

If that line exists, and by removing it you recover the prefs panel, then 
mark this as a duplicate of bug 43434. 

Comment 4

18 years ago
laurel - can you try this?  I think this may not belong to ducarroz so we may 
need to reassign pending your results.
(Reporter)

Comment 5

18 years ago
That line is NOT in my prefs.js, and I know that I am using gfx scrollbars.

Comment 6

18 years ago
No, that line is not present in prefs.js and the problem still persists.  Now,
just to reiterate, the prefs dialog is fine when called from other windows. It's
only a problem from the new message compose when launched from the browser...
Just to be clear.

Comment 7

18 years ago
Hmmm... in jun23 commercial build you can no longer access preferences in a new
message compose window which was launched from browser. Another moving target.

Comment 8

18 years ago
nominating original bug for beta3 and adding to release notes. Is there another 
bug on the preferences not being accessible from the compose window?
Keywords: nsbeta3, relnote2
Target Milestone: --- → M18
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Keywords: correctness

Updated

18 years ago
Keywords: mail2

Comment 9

18 years ago
+ per mail triage
Whiteboard: [nsbeta3+]

Comment 10

18 years ago
FYI -- aug03 beta2 build you CAN access prefs from compose window (launched from
either browser window or mail window). If you do so, Netscape hangs, must force
quit.  Verified on nbaca's mac, too.
(Assignee)

Comment 11

18 years ago
looks like something is wrong with the mail compose pref pane. If you set the 
focus into the message body and then select preference, it open the editor prefs 
instead of the mail compose one and in this case, the application doesn't hang.

By the way, the fact that we open the editor prefs while you are in the body 
could be a bug but I prefere to say that's a feature :-)
(Assignee)

Updated

18 years ago
Whiteboard: [nsbeta3+] → [nsbeta3+] Fix in hand
(Assignee)

Updated

18 years ago
Severity: minor → critical
Keywords: crash
Priority: P3 → P1
(Assignee)

Comment 12

18 years ago
Fixed and checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Whiteboard: [nsbeta3+] Fix in hand → [nsbeta3+]

Comment 13

18 years ago
FYI: I know that we won't see any fixes until the 8/11 build but this is what I 
observed with the 8/10 builds:

- NT: Preferences right side is transparent
- Linux: 
Select Edit|Preferences and nothing happens the console states
  "JavaScript error: 
  chrome://communicator/content/directory/directory.js line43: window._content     
has no properties"

Select Edit|Preferences a second time and preferences appear as an icon in the 
taskbar. I can view it by maximizing. The console states
"JavaScript error:
chrome://communicator/content/pref/nsPrefWindow.js line 88: window.arguments has 
no properties"

- Mac: The application freezes.


Comment 14

18 years ago
OK using aug15 commercial m18 build, mac OS 9.0
Prefs dialog draws fine/completely when accessed from a compose window in
browser or mail window.
Status: RESOLVED → VERIFIED

Comment 15

18 years ago
removing mail2 keyword.
Keywords: mail2
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.