The close tab button is disappearing

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
RESOLVED WORKSFORME
10 years ago
7 years ago

People

(Reporter: Tim Nugent, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-2-15])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008051206 Firefox/3.0

After Firefox crashed I restored Firefox and only the first tab had any close button, all subsequent tabs whether originally opened from the restoration or newly created have no close button.

Reproducible: Sometimes

Steps to Reproduce:
1.Crash firefox, somehow
2.Restore the session
Actual Results:  
only the first tab has a close button

Expected Results:  
all tabs should have a close button
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch

Comment 1

10 years ago
Please launch in safe mode and see what the tabs are like, also what beta version of firefox 3 are you using?
(Reporter)

Comment 2

10 years ago
This bug is hard to recreate, however I managed to crash Firefox in safe mode and the tab buttons were there.
I am using the release candidate 1 of firefox 3, but this occurred to me once before in beta 5.

Comment 3

10 years ago
I will test on my system, ill see what happens.

Comment 4

10 years ago
Firefox 3 RC1 is frequently failing to draw close buttons on tabs for me.  I have not crashed FF.  After pressing Ctrl+T once or twice, I can reliably get all close buttons to disappear with the exception of the current tab.  After closing a tab, the remaining tabs will reliably get their close buttons back.

Comment 5

10 years ago
I believe it is a feature of firefox to not display close buttons when 8 tabs are open, with the exception of the open tab.
(Reporter)

Comment 6

10 years ago
I know that, this is something different this only happens when it crashes regardless of the number of tabs

Comment 7

10 years ago
This bug is still open for Firefox 3.0. Some steps I did to reproduce this bug:

1. Start FF3 and open some tabs (I tried it with three tabs)
2. Kill FF with the task manager
3. Restart Firefox and choose to restore the session
=> Only the first tab (regardless of which one was chosen before the "crash") has a close button
4. Open a new tab
=> The new tab has no close button
5. Close FF normally and choose to save the session
6. Restart
=> All tabs have a close button again
7. Repeat steps 2 and 3
=> Close buttons are still there

However, if you first close Firefox normally, saving the session, you will not be offered to restore the session after a crash but the previously saved session will be loaded instead. Any new tabs created between restart and crash will be lost.

Btw, safe mode doesn't help because the session will not be restored there.

Actually I'm glad that I can restore the close buttons by restarting FF, but I would also like to see this bug fixed.

Comment 8

9 years ago
Seems to be a more general issue. I found a site where this issue is reproducable from scratch. (on the second tab opened!)

Steps to reproduce:
* open firefox
* open a second tab (content of first does not matter)
* second: http://www.meteox.nl/3daagse.aspx?for=1&type=regenverwachting

> "close tab" cross is not displayed.

I reduced the HTML to the following:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml"><head ><title>
	Meteox.nl - Verwachte regenval komende 3 dagen - Verwachte neerslag - Verwachte buien
</title>
</head><body >
</body></html>

If you open this in a second tab in firefox then it will demonstrate the issue!

Tested with FF 3.0.1 distibutable.

Regards,
  Fekke






Comment 9

9 years ago
Do you mean that the close button disappears immediatelly when you open that site? If so, I can't reproduce that. I also use FF 3.0.1 on WinXP. If you mean that the close button isn't shown after "killing" FF, then see my comment above - this doesn't seem to be related to special sites.

Comment 10

9 years ago
Hello Robert,

no the issue was not on killing/getting killed and restoring FF. I just stumbled across the missing "close tab" cross a couple of times and now I found a "normal" situation where the cross was missing. Formerly it appears sporadically (also in restoring sessions) so I think it is some kind of general issue, but this time I was able to replay and reproduce with the above content (and this time only on the second tab).

But you're right, after playing around with it some more (FF3.0.1 Vista) the issue disappeared after a while, cause should be the "Maximize", and "Restore Down" and the renewal of the FF instances in between.  

It sounds to me that the (saved) internal state of the window size triggers the effect and affects the calculation of tab lengths and the presented label and cross on it. Of course I tried to reproduce by changing the FF window size and doing restarts but I'm unable to get into the same situation.

I'm sorry that I didn't file a full proof example, shame that I did not exclude the external eventualities. Next time better, I'll inspect, save and document the environment also.

Regards,
  Fekke

Comment 11

9 years ago
To reproduce:

With browser.tabs.closeButtons set to 1, if you start Firefox with just one blank tab and then "Open All in Tabs" a folder in Bookmarks all of the open tabs except for the tab currently in focus will not show a close button. Once you close the last tab on the right using the close button all of the close buttons automagically appear.

Comment 12

9 years ago
(In reply to comment #8)
> Steps to reproduce:
> * open firefox
> * open a second tab (content of first does not matter)
> * second: http://www.meteox.nl/3daagse.aspx?for=1&type=regenverwachting

This doesn't work for me. I tried opening the link using a mouse menu and via Ctrl+Left Click and in both cases the grayed out [x] appeared. Please see if you can reproduce my scenario in comment #11 above.

Comment 13

9 years ago
(In reply to comment #11)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.2) Gecko/2008091620 Firefox/3.0.2

Comment 14

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.2pre) Gecko/20100308 Namoroka/3.6.2pre

Unable to reproduce. When 7 tabs are opened, Close button is not available in other tabs excluding the tab which is highlighted. When that tab is closed, close button can be seen on other tabs.

Comment 15

7 years ago
Whenever I create a new tab, all close tab buttons disappear except for current tab. Whenever I close a tab, all close tab buttons reappear.
(In reply to comment #15)
> Whenever I create a new tab, all close tab buttons disappear except for current
> tab. Whenever I close a tab, all close tab buttons reappear.

Benjamin, you are probably using a Firefox 4.0 build and seeing bug 586666 which has been fixed recently.

Anyone else with an older build (i.e. 3.6 branch) who can still see this behavior?
Whiteboard: [closeme 2010-09-01]

Updated

7 years ago
Whiteboard: [closeme 2010-09-01]
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2011-2-15]

Comment 18

7 years ago
I haven't seen the problem since my latest report (two years ago).
Using 3.6.latest (currently 13).
I assume it has vanished due to other code changes, I think we can close.
Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.