when saving a bookmark, as you are hovering over to a subfolder that subfolder will disappear

RESOLVED DUPLICATE of bug 422626

Status

()

--
major
RESOLVED DUPLICATE of bug 422626
10 years ago
9 years ago

People

(Reporter: electron369, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0

In browser mode, when you are dragging a web page up to a subfolder or sub subfolder in your main bookmark menu (not the hot purple display book button) when you are hovering over to a subfolder that subfolder will disappear,it seems to be to sensitive or a time delay problem.


Reproducible: Always

Steps to Reproduce:
1.drag the web page that you are on, up to the main bookmark menu
2.your bookmark menu will open, hover over one of your folders
3.then go in and then hover over a subfolder and drop it into a subfolder
Actual Results:  
when you try to hover over the subfolder that subfolder disappears and you can
not drop your bookmark in to the subfolder

Expected Results:  
drop your bookmark in to the subfolder
Confirmed, it is a very annoying bug that makes it hard, nearly impossible to drag your bookmarks into the sub menus. I believe this could a duplicate, but I'm not sure. At least I'm sure there is a bug for mouseover, not sure for dragover. I can't find a regression range for this, because bug 337761 prevents from testing this in older places-enabled builds.
It's much more difficult (but not impossible) to reproduce in non-places builds, because I believe the gap between menus is larger in places builds.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
Component: Bookmarks → Places
QA Contact: bookmarks → places
(Reporter)

Comment 2

10 years ago
To reproduce the problem (which happens most of the time)you must make folders,sub folders,sub sub folders and bookmarks all of those menu.(a menu being a list of bookmark and or folders,with in a folder ) IT is when you are dragging and dropping a bookmark going from a sub folder to that sub menu. The sub menu disappears, that is when the problem occurs. 

I made sure i deleted my Firefox profile file and re installed Firefox 3 Release Candidate and steal have the problem.  problem not isolated to fox 3rc or 3 betas.
i don't see the problem on Vista, do you see a white space between menus? there is a bug report about a gap between menus and submenus that cause the submenu to close, could this be the case?
(Reporter)

Comment 4

10 years ago
i don't see a white space, the only thing that happens is the submenu disappears when I'm dragging and dropping a bookmark going from a sub folder to that sub menu or as you say it, closes. the gap that you type about, what is the bug number and is it related to dragging and dropping a bookmark in a submenu.  

im using xp  

Comment 5

10 years ago
Try bug 422607
(In reply to comment #5)
> Try bug 422607
>
No, this is not the same. Dragover is different from mouseover. The gaps are not on the same spots, at least not here. The problem seems to be the few pixels before the favicons. When I, dragging a bookmark, put my mouse on this spot, the menu opens and closes continuously as long as my mouse stays there. The highlights are also very strange. 

(Reporter)

Comment 7

10 years ago
i have notice that if i move very very quickly (Dragover) from sub folder to sub menu it sometime works. 

Comment 8

10 years ago
You filed four identical bugs about this problem.  I'm duping the three newest ones to the oldest of these four bugs, and then I will dupe that to bug 419911.  If you feel that bug 419911 is not the same problem, please reopen bug 422626.  In the future, please open only one bug per issue; unless the bug has been marked as FIXED, there is no need to open a new one for each new version.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 422626
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.