Bookmark appear duplicated in both toolbar and chevron menupopup while reordering

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
trivial
RESOLVED WORKSFORME
10 years ago
5 years ago

People

(Reporter: Martijn Smit, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0

Reordering bookmarks inside the more... foldout (right-hand side of the bookmarks toolbar) can mean that suddenly the first item on the list is short enough to fit on the toolbar after all; it will do so, but not disappear from the foldout menu until you reopen the menu.

Reproducible: Always

Steps to Reproduce:
1. Create so many bookmarks in your toolbar that they don't fit on one line, but that there is some space left.
2. Make sure you have at least two bookmarks in the more... foldout: one with a long name at the top, and one with a short name below, that would fit in the available space.
3. Open the foldout, drag the short bookmark to the top. Notice it appears in the space that was left on the toolbar, but is not removed from the foldout.
Actual Results:  
Dragged bookmark remains in foldout.

Expected Results:  
Dragged bookmark disappears from foldout when it appears in toolbar.

Comment 1

10 years ago
i have seen this sometime, so i can somehow confirm, but probably there's an older bug about this. The bookmark is not duped but is a view glitch probably due to an incorrect update of the chevron view.

Comment 2

10 years ago
confirming but look around for a dupe
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: DUPEME?

Updated

10 years ago
Summary: Updating more... foldout on bookmarks bar when reordering → Bookmark appear duplicated in both toolbar and chevron menupopup while reordering

Updated

9 years ago
Whiteboard: DUPEME?
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
this should now be WFM
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.