input type=file background-color property not respected

RESOLVED DUPLICATE of bug 419973

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 419973
10 years ago
10 years ago

People

(Reporter: Timwi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

314 bytes, text/html
Details
(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.9) Gecko/2008051206 Firefox/3.0

The background colour of an <input type='file'> should be rendered according to the background-color CSS property. This was the case in Firefox 2, even for disabled input controls.

Reproducible: Always

Steps to Reproduce:
1. Look at attached testcase
Actual Results:  
Background is white (default)

Expected Results:  
Background should be red (as declared in CSS)
(Reporter)

Comment 1

10 years ago
Created attachment 321615 [details]
Testcase

Comment 2

10 years ago
You might want to attach your testcase on the other bug, but it has more flags set and is older, so duping against that one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 419973
You need to log in before you can comment on or make changes to this bug.