All users were logged out of Bugzilla on October 13th, 2018

Problems with copying and pasting contents of embedded bookmark folders to new location when organizing bookmarks.

RESOLVED DUPLICATE of bug 425884

Status

()

RESOLVED DUPLICATE of bug 425884
11 years ago
9 years ago

People

(Reporter: lenoreyoung07, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008043010 Fedora/3.0-0.60.beta5.fc9 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008043010 Fedora/3.0-0.60.beta5.fc9 Firefox/3.0b5

When importing bookmarks, I noticed this error. I have bookmark folders, some of which contain folders themselves, with bookmarks in them. When copying and pasting contents of parent folder to Personal Toolbar folder, only the contents of the parent folder, and the embedded folder(s) itself is copied/pasted correctly. Any contents of the embedded folder, however, do not copy/paste over correctly to new location. (Embedded folder is empty in new location.)


Reproducible: Always

Steps to Reproduce:
1. Choose a folder full of bookmarks, which also contains a secondary folder of bookmarks. 
2. Copy the contents of the parent folder of bookmarks (selecting the internal folder as well).
3. Paste contents of parent folder to Personal Toolbar.

Actual Results:  
The contents of the parent folder pasted correctly, but the embedded folder itself only pastes over, not the contents of the embedded folder.

Expected Results:  
Contents of embedded folder should have been copied and pasted correctly.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008051522 Minefield/3.0pre

It works here, but it takes extremely long (several minutes). I believe one of the sub-folders showed only its contents after second mouseover.
Component: Bookmarks → Places
QA Contact: bookmarks → places
Version: unspecified → Trunk

Comment 2

11 years ago
this should have been fixed in bug 425884
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 425884
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.