Closed Bug 434781 Opened 14 years ago Closed 14 years ago

Add RSA support to crypto component

Categories

(Cloud Services :: General, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 433949

People

(Reporter: hello, Assigned: Dolske)

References

Details

WeaveCrypto currently only supports PBE operations.  It needs to also handle RSA:

* key generation
* encryption/decryption of the private key
* encryption/decryption of data with the private/public keys
* base64/ascii armoring for distribution of everything
Assignee: nobody → thunder
Priority: -- → P1
Target Milestone: -- → 0.2
Assignee: thunder → dolske
All the fun is over in bug 433949; duping.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 433949
Component: Weave → General
Product: Mozilla Labs → Weave
QA Contact: weave → general
You need to log in before you can comment on or make changes to this bug.