Testopia not stable under Internet Explorer

RESOLVED DUPLICATE of bug 368034

Status

--
minor
RESOLVED DUPLICATE of bug 368034
11 years ago
11 years ago

People

(Reporter: bvandermerwe, Assigned: gregaryh)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: 2.0 (on Bugzilla 3.0.x)

Testopia works fine under Firefox, but our tested originally unexpected ran it under IE. Under IE you notice the following:

"If you edit the header section of a previously saved test case using IE6 pressing commit promptly sets the action, expected results and other fields to undefined. You can get around this by opening all the fields for edit before saving but about 30% of the time it seems to dump the entire page description into the edit box.

I made the mistake of pressing commit after one incidence which is why one of the test cases is corrupt. Even including this case in the case list without expanding it screws the rest of the page up.

It has also hung a couple times - but not in any reproducible manner."

Our server is running very recent stable versions of Bugzilla, Apache, Perl etc.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Personally I love and use Firefox. The person who reported this to me and is using Testopia, also ended switching. Your web site states that Tesopia has only been thoroughly tested on Firefox. This is quite possibly a bug in IE and thus something that you cant fix. So why am I reporting it?
- It might be useful to put in the notes,
- It may actually a bug or glitch in Testopia somehow,
- You may some day want to make sure it works on all browsers and thus this may be handy.

Comment 1

11 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14)
> Gecko/20080404 Firefox/2.0.0.14
> Build Identifier: 2.0 (on Bugzilla 3.0.x)
> 
> Testopia works fine under Firefox, but our tested originally unexpected ran it
> under IE. Under IE you notice the following:
> 
> "If you edit the header section of a previously saved test case using IE6
> pressing commit promptly sets the action, expected results and other fields to
> undefined. 

Dumb question, perhaps, but are you sure you were running Testopia 2.0 at the time? We've seen this problem with earlier versions of Testopia, but not 2.0....
(Reporter)

Comment 3

11 years ago
(In reply to comment #1)

I am quite sure we installed Testopia 2.0, since I installed it. But is there a way to make absolutely sure?

Comment 4

11 years ago
look at testopia/template/en/default/hook/index.html.tmpl/links/tr.html.tmpl
(Reporter)

Comment 5

11 years ago
Oops, my sincerest apologies... According to that link we are using Testopia 1.3. I can swear I installed 2.0 but I must be mistaken.

Is upgrading to 2.0 relatively painless? (I had a lot of trouble getting 1.3 to work. Upgraded everything, but bugzilla was incompatible with the latest stable perl version, I downloaded and unzipped the dojo source as per one installation instruction set, which didnt work and I only figured that out after comparing directories against the Testopia virtual test machine, etc.)

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 368034

Comment 7

11 years ago
(In reply to comment #5)
> Oops, my sincerest apologies... According to that link we are using Testopia
> 1.3. I can swear I installed 2.0 but I must be mistaken.

No problem.

> Is upgrading to 2.0 relatively painless? (I had a lot of trouble getting 1.3 to
> work. Upgraded everything, but bugzilla was incompatible with the latest stable
> perl version, I downloaded and unzipped the dojo source as per one installation
> instruction set, which didnt work and I only figured that out after comparing
> directories against the Testopia virtual test machine, etc.)

You might wish to ask the mailing list or the Testopia IRC channel. Note that ghendricks will be out of the office for a few days.

Comment 8

11 years ago
BTW, Testopia 2.0 doesn't use dojo. Note also that the latest JSON is not compatible with Testopia. There are several bugs on that topic -- you might want to search for them in this bugzilla -- product=testopia
You need to log in before you can comment on or make changes to this bug.