about:about file not found in Firefox

VERIFIED DUPLICATE of bug 349451

Status

()

Core
Document Navigation
VERIFIED DUPLICATE of bug 349451
10 years ago
10 years ago

People

(Reporter: glandium, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Created attachment 321820 [details] [diff] [review]
patch

When going to about:about in Firefox 3.0rc1, you get a File not found error, because aboutAbout.html is not included, which, when you take a look at xpfe/Makefile.in, you understand why: xpfe/global is only built when NS_XUL_APP is not defined.

This means about:about shouldn't even be registered, which this patch fixes.
Attachment #321820 - Flags: review?(benjamin)
Alternately, the firefox build stuff should be changed to build about:about.... either way.
(Reporter)

Comment 2

10 years ago
Or, other possibility, move aboutAbout to toolkit...
Dupe of Bug 349451 ? 
That patch preserves about:about for Camino, while breaking SeaMonkey's "I'm a MOZ_XUL_APP, but I don't agree with the Firefox drivers that about:about is stupid" copy in /suite/browser/aboutAbout.html (which makes it slightly better than the last patch in a dupe, which just broke it for everyone).

(Firefox's "no no no, we hates about:about we does" bug is bug 220253).
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 349451

Updated

10 years ago
Attachment #321820 - Flags: review?(benjamin)
v.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

10 years ago
(In reply to comment #4)
> That patch preserves about:about for Camino, while breaking SeaMonkey's "I'm a
> MOZ_XUL_APP, but I don't agree with the Firefox drivers that about:about is
> stupid" copy in /suite/browser/aboutAbout.html (which makes it slightly better
> than the last patch in a dupe, which just broke it for everyone).

Actually, seamonkey's solution is to register the about:about handler itself, and having both toolkit and seamonkey register it mean seamonkey's win, because it's loaded after (as being external component, contrary to internal nsAboutRedirector component), which makes the present patch work in both cases.

> (Firefox's "no no no, we hates about:about we does" bug is bug 220253).

And the rationale was that about:config should not be exposed. OTOH, now, about:config has a huge warning...
Blergh. You'd think I'd remember having filed bug 365852, where the wontfix directly resulted in bug 363491 reimplementing it for /suite, meaning your patch is just the final part of implementing what bsmedberg wanted instead of bug 365852. Still a duplicate, though.

And yes, none of the reasons why Firefox doesn't implement it make much sense, but then they never really did, which makes me think it's an emotional decision being continually papered over with whatever explanation might work at the time, so despite having just started in on what must be my fourth or fifth patch to implement it for Firefox (this one even had both l10n and style), I think I'll just give up, again.
You need to log in before you can comment on or make changes to this bug.