Nothing happens when "Back up bookmarks" is clicked

RESOLVED FIXED in 0.2

Status

Cloud Services
General
P1
normal
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: Ryan Steele, Assigned: myk)

Tracking

unspecified
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: 0.1.29

I installed the plugin on my Windows XP machine with Firefox 3 RC1. I click "Tools > Weave > Sign in..." and click Next to go to step 2 of the Weave setup wizard. When I click the "Back up bookmarks" button, nothing happens. The following error shows up in the Error Console:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Firefox%203%20Beta%205/modules/utils.js :: PU_getString :: line 173"  data: no]

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

10 years ago
Possibly the interface for backing up bookmarks have changed.  We'll investigate.
Blocks: 433899
Priority: -- → P1
Target Milestone: -- → 0.2
(Assignee)

Comment 2

10 years ago
Looking.  I suspect perhaps the properties file doesn't get loaded automatically on Windows and Linux.
Assignee: nobody → myk
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

10 years ago
Created attachment 321995 [details] [diff] [review]
patch v1: fixes problem

There are two places.properties files, one exposed by PlacesUtils, the other by PlacesUIUtils.  The two strings being used by bookmark backup are accessible via the latter interface.  Here's a patch that grabs them from there instead.
Attachment #321995 - Flags: review?

Comment 4

10 years ago
Comment on attachment 321995 [details] [diff] [review]
patch v1: fixes problem

Cool.  Commit away!
Attachment #321995 - Flags: review? → review+

Comment 5

10 years ago
Has it been committed? Is this fix in Weave 0.1.30? I'm asking because when installing 0.1.30, bookmarks backup didn't work too.
(Assignee)

Comment 6

10 years ago
Yes, this was fixed in revision 896157149a3e <http://hg.mozilla.org/labs/weave/index.cgi/rev/896157149a3e> and is part of Weave 0.1.30.  Does bookmarks backup fail in the same way for you (i.e. nothing happening except for that error showing up in the error console)?

Comment 7

10 years ago
I figured out that in my case, although the symptom was the same (nothing happening on backup), it was due to corrupted bookmarks interrupting the process - see bug 436696.
(Assignee)

Comment 8

10 years ago
This bug is fixed, so resolving as such.  But as Aleksander noted, there are some related issues per bug 436696.  I'll follow up on those there.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

9 years ago
Component: Weave → General
Product: Mozilla Labs → Weave
QA Contact: weave → general
You need to log in before you can comment on or make changes to this bug.