mozilla.com file names should also be localized

RESOLVED WONTFIX

Status

www.mozilla.org
General
RESOLVED WONTFIX
10 years ago
6 years ago

People

(Reporter: Fernando Pereira Silveira, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: 

As part of the effort to localize mozilla.com, the file names should also be localized. The file names make no sense to users who don't speak English.

Maybe a per-locale redirection map could help?

Reproducible: Always
Pretty sure this isn't possible given our current set up and how we redirect based on if a file exists or not. If we were to do this, it would take a lot of work and time, and I don't think we have the time at all to do something like this. I also don't think it's entirely needed, as the user is more interested in the content of the page as compared to the filename of the page.

Comment 2

10 years ago
hey Pascal, 

What are the chances we would have a sort of mapping between the en-US names
and a pt-BR one? Would be cool to also be able to work on a file with the same
_base name and then just apply the bindings, so that aliases are served. 

Comment 3

10 years ago
This would help us with search engine ranking too, big requisite from BR for a new feature.  
the amount of work required and maintenance would be huge , the benefits would be marginal I am in favour of marking this bug wontfix.

Comment 5

10 years ago
Investigation on the benefits, specifically for medium long term, is a must here for us in Brazil and other future mozilla.com incountry customers IMHO. But I do understand if this is not appropriate at this time considering the amount of work our current system framework would demand. I believe there is a room for us to think about how countries sees URLs in terms of localized documents, and specifically knowing that it is natural that new documents ( not cloned ) will be also created eventually. 

Due to the reasons already mentioned I'm wontfixing this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

6 years ago
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
(Assignee)

Updated

6 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.