All users were logged out of Bugzilla on October 13th, 2018

After browsing for a while, Youtube and other sites fail to render properly

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: r_carollo, Unassigned)

Tracking

3.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008051202 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008051202 Firefox/3.0

After an indeterminate amount of time, Firefox will fail to correctly render pages on Youtube and Facebook. This may also affect other pages, but I have seen this behavior on these sites. Graphics tend not to display well and text is in bizarre, often unreadable positions. Links do not always function properly. The page will usually be many times "longer" than it should be because of the poor formatting.

Switching web sites does not clear the problem (i.e., Facebook will tend to show the same problem once Youtube has manifested it). The issue is temporarily resolved by restarting Firefox.

Reproducible: Sometimes

Steps to Reproduce:
1.Use browser for a significant time period (~hours)
2.Navigate to Youtube or Facebook page
3.Page style will be severely malformed on at least some pages
Actual Results:  
The pages were malformed. Up to a certain point there was no issue, but pages loaded after that tend to have bad formatting.

Expected Results:  
The page is expected to render normally.

This bug occurs in Firefox 3 RC1, but I have also seen it in several versions of Firefox 2. I don't believe this is unique to Firefox 3.
(Reporter)

Comment 1

11 years ago
Created attachment 321883 [details]
correctly rendered page in Safari
(Reporter)

Comment 2

11 years ago
Created attachment 321884 [details]
Incorrectly rendered page in Firefox 3 RC1
(Reporter)

Comment 3

11 years ago
Created attachment 321886 [details]
Incorrenctly rendered Facebook page in Firefox 3 RC1

Comment 4

11 years ago
I have the same problem...
(Reporter)

Comment 5

11 years ago
I noticed some additional symptoms that appear to be related to the same issue. Once this condition occurs, several elements of the Firefox interface appear to become inoperable. I was unable to open a new window, the preferences pane, or the "Clear Private Data" window. I have also been unable to open some web pages from the bookmark or location bars in a new tab (but some of these links will open). The Home button is also not working.
(Reporter)

Comment 6

11 years ago
The bug also appears in Firefox 3 RC2
Version: unspecified → 3.0 Branch

Comment 7

10 years ago
I too experience this problem.  The page usually renders incorrectly as the attachments show, but sometimes only a few things don't render correctly (missing images, etc... this may be a different bug altogether).  Sometimes hyperlinks stop working.  This never happened for me with version 2 or the V3 RCs, though.
(Reporter)

Comment 8

10 years ago
This big is still recurring regularly on my fully-updated version 3.0.1 install. As a workaround I have been killing the process from the Terminal and restoring the previous session to maintain my open tabs at restart. This is very reproducible - it happens to me almost every day. Is there something I could do to provide more information?
(Reporter)

Comment 9

10 years ago
(In reply to comment #8)
Sorry, that was supposed to be "This bug..."
(Reporter)

Comment 10

9 years ago
I no longer observe this bug as of 3.5. Since I filed it, I'm going to mark it 'resolved: fixed'.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
since we don't know what patch fixed it, wfm.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.