[Canvas.drawImage] Image failed to load while running my application

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: parthiban.bala, Unassigned)

Tracking

({regression})

1.8 Branch
x86
Windows Server 2003
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.2; SV1; .NET CLR 1.1.4322; .NET CLR 3.0.04506.30; .NET CLR 3.5.21022; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

I am using an open source photo browser called mooflow in my application. I'm getting following exception in the error console while runs the page

uncaught exception: [Exception... "Component returned failure code: 

0x80040111 (NS_ERROR_NOT_AVAILABLE) 

nsIDOMCanvasRenderingContext2D.drawImage" nsresult: "0x80040111 

(NS_ERROR_NOT_AVAILABLE)" location: "JS frame
file:///C:/Documents%20and%20Settings/parthiban/Desktop/Javascript-1/javasc

ript/MooFlow.js
anonymous :: line 77" data: no]

FYI: MooFlow 1.2. A sleek image slideshow mimicking Apple's famed Cover Flow interface. Uses MooTools. ()

I have found the drawImage is an issue by debug the demo application by downloading from the site. - http://www.outcut.de/MooFlow/

I even googled the web and come to know that the exception throws because of the firefox fail to support drawImage().

I saw the issue was occured in FireFox/2.0.0.10. But it still persists in the current version (Firefox/2.0.0.14)


Reproducible: Always

Steps to Reproduce:
1.Download the demo application from the site(http://www.outcut.de/MooFlow/).
2.Open the html page in Firefox/2.0.0.14.
3.
Actual Results:  
The spinner image alone rotates. The following exception throws in Error Console.

uncaught exception: [Exception... "Component returned failure code: 

0x80040111 (NS_ERROR_NOT_AVAILABLE) 

[nsIDOMCanvasRenderingContext2D.drawImage]" nsresult: "0x80040111 

(NS_ERROR_NOT_AVAILABLE)" location: "JS frame :: 

file:///C:/Documents%20and%20Settings/parthiban/Desktop/Javascript-1/javasc

ript/MooFlow.js :: anonymous :: line 77" data: no]


Expected Results:  
The image have to load while run the application.

It works fine in IE6

Comment 1

11 years ago
Regression? According to Bug 405584 this was fixed in 1.8.1.11/1.8.1.12
Component: Error Console → Layout: Canvas
Keywords: regression
Product: Firefox → Core
QA Contact: error.console → layout.canvas
Version: unspecified → 1.8 Branch

Updated

11 years ago
Severity: critical → normal

Updated

11 years ago
Summary: Image failed to load while running my application → [Canvas.drawImage] Image failed to load while running my application
this is WFM using
Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.8.1.20) Gecko/20081217 Firefox/2.0.0.20 ID:2008121709
and newer branches.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.