Spell check options not shown if I use the menu key

VERIFIED DUPLICATE of bug 370436

Status

()

--
minor
VERIFIED DUPLICATE of bug 370436
10 years ago
10 years ago

People

(Reporter: calebegg, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008050509 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008050509 Firefox/3.0b5

My normal method for correcting a spelling error after I type a word is to use the left arrow twice to move into the word and then press the menu key to bring up the context menu, then press the down arrow to pick the correct spelling. In the 3.0 betas, the context menu doesn't show the spell check options if I use the menu key; it only shows spell check options if I right click.

Reproducible: Always

Steps to Reproduce:
1. Type a misspelled word in a spell checked field.
2. Press the left arrow key twice (or more) to move your keyboard cursor to the word
3. Press the menu key to bring up the context menu
Actual Results:  
There are no spell check results in the context menu after opening it in that manner. There are spell check results if I perform an actual right click.

Expected Results:  
I expected there to be spell check results in the context menu, per version 2.0 and other programs with similar spell check functionality, and also because the context menu should be the same, regardless of whether or not I choose to use a mouse or my keyboard to open it

This is the first time I've reported a bug for Firefox (or any major open source software), so if I screwed something up badly, please be nice. :-)

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 370436
V.Duplicate
Status: RESOLVED → VERIFIED
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.