Closed Bug 435027 Opened 15 years ago Closed 14 years ago

contact not removed from search results display after contact is deleted

Categories

(MailNews Core :: Address Book, defect, P1)

x86
Windows XP
defect

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b1

People

(Reporter: wsmwk, Assigned: standard8)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

contact not removed from search results display after contact is deleted. Not 100% sure whether regression is from bug 434528 checkin or not.
WFM version 3.0a2pre (2008051203)
fails version 3.0a2pre (2008052103)

1. quick search on part of name 
2. delete a contact

results: it's still in the display. clear the search field and you can see the contact was deleted.
I think we should get this on the radar for 3.0a2, probably an easy fix.
Flags: blocking-thunderbird3.0a2?
I don't think this needs to block a2, wanted though. (And marking  	 blocking‑thunderbird3+)
Flags: wanted-thunderbird3.0a2+
Flags: blocking-thunderbird3.0a2?
Flags: blocking-thunderbird3+
I'm wondering if we should relnote this, considering that we have fixed the update of the displays for things like add and delete in address book where we aren't searching.
Keywords: relnote
Product: Core → MailNews Core
Flags: blocking-thunderbird3+ → wanted-thunderbird3+
Priority: -- → P1
Target Milestone: --- → Thunderbird 3.0b2
This bug is still present in tb3a3.
Attached patch WIP v1 (obsolete) — Splinter Review
This patch is a WIP. It fixes the delete within search when you're doing quick search on an address book.

I'm still working on the fix for the delete within a mailing list quick search. I know roughly what the problem is, in case I don't get to it tomorrow, then noting down issue for later:

The problem is that the locally stored prefs id isn't initialised for a nsAbMDBDirectory that is a search query. When we try and keep a reference to the nsIAddrDatabase in nsAbMDBDirectory::DeleteCards, it fails, because we haven't got the prefs, and hence we can't get the nsIAddrDatabase. We can't even get the non-search database, because mailing lists still don't know about the locally stored prefs. I need to ponder this some more.
Assignee: nobody → bugzilla
Status: NEW → ASSIGNED
I've changed my mind on what I'm going to do for this bug. I'll fix the update of the display here (which I can do for b1), which I consider the more major problem as this affects the contact sidebar as well, and then I'll file a follow-up bug to fix the delete whilst searching on a mailing list bug.

This patch still fixes the problem in the same way as WIP v1 (account for search uris as well), but just adds some more explicit comments.
Attachment #348564 - Attachment is obsolete: true
Attachment #348755 - Flags: superreview?(bienvenu)
Attachment #348755 - Flags: review?(bienvenu)
Comment on attachment 348755 [details] [diff] [review]
Fix the update of the display.

so nice to have this fixed!
Attachment #348755 - Flags: superreview?(bienvenu)
Attachment #348755 - Flags: superreview+
Attachment #348755 - Flags: review?(bienvenu)
Attachment #348755 - Flags: review+
I raised bug 465535 for the delete within mailing list quick search issue.

Checked in this patch: http://hg.mozilla.org/comm-central/rev/4210261cd843
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.