in vista, launching firefox from an application running in xp compatibility mode loads the xp theme

RESOLVED INVALID

Status

()

Firefox
Theme
RESOLVED INVALID
10 years ago
9 years ago

People

(Reporter: James [silentj], Unassigned)

Tracking

3.0 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008051906 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008051906 Minefield/3.0pre

in windows vista, if you launch firefox by clicking a http link from an application running in xp compatibility mode firefox will start with the xp theme

Reproducible: Always

Steps to Reproduce:
1. set firefox as your default browser
2. download and install klipfolio
3. change the compatibility options for klipfolio to xp
4. run klipfolio
5. click a link to launch firefox

Actual Results:  
firefox has the xp theme not the vista theme

Expected Results:  
firefox should have the vista theme
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch

Comment 1

10 years ago
It's a little difficult for Firefox to detect that it's on Vista if Vista is masquerading as XP (which is what compat. mode does).

Comment 2

10 years ago
This is normal behaviour in Vista. If an app is launched using compatibility mode Aero is disabled, and stays disabled until you close the app running in compatibility mode.
(Reporter)

Comment 3

10 years ago
that's not what I'm reporting here...

Firefox itself is not set to use any compatibility mode - I'm just launching it via clicking a URL from another app running in compatibility mode, that IMHO should just launch a normal Firefox session, not one running in compat mode
(In reply to comment #3)
> that's not what I'm reporting here...
> 
> Firefox itself is not set to use any compatibility mode - I'm just launching it
> via clicking a URL from another app running in compatibility mode, that IMHO
> should just launch a normal Firefox session, not one running in compat mode

Firefox doesn't control that, Windows does.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Updated

9 years ago
Duplicate of this bug: 440625
You need to log in before you can comment on or make changes to this bug.