Upgrading when using incompatable extension "Compact Menu 2" removes access to the menu bar

RESOLVED INVALID

Status

()

Toolkit
Application Update
--
major
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Kris Bloe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9) Gecko/2008051206 Firefox/3.0

I use the "Compact Menu 2" extension v2.1.4. When upgrading to a new, incompatable version, the menubar (which I hadsitting on my Navigation bar) is removed and I have no way of re-enabling it.

Last time this happened (from v2 to 3b5), I uninstalled 3b5, went into v2 and placed the Menu bar to it's proper location then upgraded again. This worked fine, but I should not have to do this.

Reproducible: Always

Steps to Reproduce:
1. (on an old, compatable version) install "Compact Menu 2" extension v2.0.4 and 'hide' the main menu bar.
2. Place the extension's menu onto the Nav. bar.
3. Upgrade to the new version of FF3.
Actual Results:  
When I right click, I get the option to add the "Navigation Toolbar" and the "Bookmarks Toolbar" only.

Expected Results:  
Enabled me to get the Menu bar back. In FF2, the option was still there, when the ext. was installed and running. Somwehere, the option has been disabled. This will either be due to FF or the ext.

No errors, but I used "Aquatint Black" v1.1.1 in FF2, which was disabled in FF3rc1 due to incompatability.

I have not tried it without this theme enabled.
(Reporter)

Updated

10 years ago
Summary: Upgrading when using extension "Compact Menu 2" removes menu bar as not compatable → Upgrading when using incompatable extension "Compact Menu 2" removes access to the menu bar
(Reporter)

Updated

10 years ago
Severity: normal → major
(Reporter)

Comment 1

10 years ago
The bar returns if the ext. is uninstalled.

Even so, the bar should be shown if the ext. is not being used due to incompatability.
(Reporter)

Comment 2

10 years ago
No longeer valid, as v2.1.0 solves this problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.