Non-deterministic rendering of elements nested inside anchors

RESOLVED DUPLICATE of bug 324875

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 324875
10 years ago
9 years ago

People

(Reporter: Bernard sumption, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-GB; rv:1.9) Gecko/2008051202 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-GB; rv:1.9) Gecko/2008051202 Firefox/3.0

The linked page contains 20 or so anchor elements with a display:block style, and other block elements like p, h2 and h3 nested within the anchors.

Sometimes the nested elements appear to the side of the anchors they are supposed to be inside. This happened on the recent versions of Firefox 2, and I upgraded to Firefox 3 rc1 to confirm that it is still there.

This only happens to 2 or 3 of the anchors on the page, even though the HTML structure of each anchor is the same.

It doesn't happen when I load the page from my filesystem, or when all the images on the page are cached - only the first time I visit the page, or on forcing a clean refresh.

Confirmed on a PC and a Mac OS X.

Interestingly, the DOM is different in the incorrectly rendered anchors, indicating that this might be a parsing bug rather than a rendering one?

Reproducible: Always

Steps to Reproduce:
1. Clear cache
2. Load http://www.sofobomo.org/projects.html
Actual Results:  
Nested elements appear outside parent

Expected Results:  
Nesed elements appear inside parent.

Comment 1

9 years ago
Thanks for reporting.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 324875
You need to log in before you can comment on or make changes to this bug.