Crash after deleting all of Today's history in the history toolbar and then navigating to a new webpage in a tab

RESOLVED FIXED

Status

()

Firefox
Bookmarks & History
--
critical
RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: Jonathan Uy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0

Pretty much as the summary says.  It may be worth noting though that I was unable to reproduce it when deleting all of a day's history from 2 days or 3 days ago.

Reproducible: Always

Steps to Reproduce:
1. open up multiple tabs and build up a history
2. Ctrl+H to open history side bar
3. select "Today"s history, and delete it all
4. in one of the open tabs, navigate to another page
- I first noticed it when selecting a webpage from my Bookmarks Toolbar, and was able to reproduce it consistently there.  But navigating using the address bar also seems to repro just as well.
Actual Results:  
Crash

Expected Results:  
No crash :)
Did you submit crash reports to Mozilla ? 

In the address/url bar enter:  about:crashes 
copy/paste the crash ID url in this bug

Comment 3

10 years ago
Fx3rc1, 10.4.11, confirmed crash on Mac.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → 3.0 Branch

Comment 4

10 years ago
Fx3rc1, on Ubuntu 8.04, confirmed in Linux as well.
Component: History → Places
OS: Windows XP → All
QA Contact: history → places
Hardware: PC → All
Looking at the crash reports from comment #2, your hitting a 'top-crasher'

Duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=433525 ?

Component: Places → History
OS: All → Windows XP
Hardware: All → PC
Version: 3.0 Branch → unspecified
The fix for 433525 has just landed, should be in a build in about 4-5 hours...
Can you re-test for your crashes?

(Reporter)

Comment 7

10 years ago
Cool, how would I get the updated build?
You can either download an hourly build, or wait till RC2 comes along.  I have no info on when RC2 will be coming out..as they are still testing RC1.  

If your interested you can get the latest hourly here: 
http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/FX-WIN32-TBOX-mozilla1.9.0/1211560020/

I have just tested using the hourly build and I can confirm that the crash is gone.  I was able to repo the crash and now I cannot.

This is fixed it appears using:
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008052310 Minefield/3.0pre Firefox/3.0 ID:2008052310
Vista HP SP1

(Reporter)

Comment 10

10 years ago
Tested using hourly build from 5/23/08 11:15 pacific time, and can confirm the fix.  No longer seeing the crash on WinXP
Fixed on branch by https://bugzilla.mozilla.org/show_bug.cgi?id=433525

Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.