If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Deleting Recently Bookmarked folder item should not actually delete bookmarks but instead remove them from the Recently Bookmarked menu.

RESOLVED DUPLICATE of bug 432019

Status

()

Firefox
Bookmarks & History
P2
normal
RESOLVED DUPLICATE of bug 432019
10 years ago
8 years ago

People

(Reporter: lech, Unassigned)

Tracking

3.0 Branch
Firefox 3.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0

I was not aware that deleting items from within the "recently bookmarked" menu represented the actual bookmarks themselves. As a result I accidentally hosed about a quarter of my bookmarks in an attempt to clear the list. Hooray for backups so nothing was actually lost. However, other users however might not like the results following a similar strategy.

Reproducible: Always

Steps to Reproduce:
1. Within the bookmarks menu or manager, navigate to the "Recently Bookmarked" item.
2. In a vain attempt to "clear" or "disable" the "Recently Bookmarked" folder, start deleting some familiar recent bookmarks you know the location to.
3. Go find those bookmarks you just deleted in the place they were originally located.
4. Learn they're totally hosed!
Actual Results:  
Bye Bye Bookmarks!

Expected Results:  
I think for the sake of safety, Firefox should populate this folder as a separate list. This way if a user does want to keep the link but not have it appear in their Recently Bookmarked folder, they can safely delete it.

A pref to disable either the display of the folder, collection of recently bookmarked items or a combination of the both would also be ideal here. I'm probably not the only one who might compare this to the windows "Documents" start menu item, but even that has an option to safely flush its contents without the actual files and also a power-user add-on to completely disable it. So far I haven't been able to find a pref similar to do either in FF3 RC1.
(Reporter)

Updated

10 years ago
Summary: Deleting Recently Bookmarked folder item should not actually delete bookmarks but instead remove them. → Deleting Recently Bookmarked folder item should not actually delete bookmarks but instead remove them from the Recently Bookmarked menu.

Updated

10 years ago
Component: Bookmarks → Places
QA Contact: bookmarks → places
Version: unspecified → 3.0 Branch
The folder has *dynamic* contents. It shows the results of a query, each time it's opened. In this case, it queries for the most recently added bookmarks.

So your request to have specific items remove from the query results, while *not* deleting the bookmarks themselves is infeasible.

I think we have two options here:

1. leave the behavior as is, but make it visually clearer that the user is acting on the source item itself. eg, a prompt.

2. make the child items of queries read-only.

Comment 2

10 years ago
If we take option 2 (make the items read-only), it might make sense to add a "Reveal in Organizer" context menu item.  This would give users who really do want to edit the bookmark a way to do it, while hopefully making it clear what it is they are editing.  This is similar to what Tiger's Spotlight does.
(Reporter)

Comment 3

10 years ago
If going the route of option #2, I think replacing the "delete" menu item with "reveal in organizer" as Jesse is suggesting would be a good start. Popping unnecessary warning dialogs here would be slightly more annoying than simply redirecting the user to where the bookmark actually is within the manager.

While I understand that this folder has dynamic content which physically links the actual bookmarks within this list. I believe it would behave better if wasn't and this was an associated list instead. This way it could be cleaned out along with cache and history or flushed/disabled from within it's sub-menu. I understand it's too late for this to appear now, but it would be nice to consider something like this for a distant patch or future roadmap.

On a side note: Is there currently any pref to disable and/or hide the display or collection of recently bookmarked or tagged items from the bookmarks menu?
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Priority: -- → P2
Hardware: PC → All
Target Milestone: --- → Firefox 3.1
(In reply to comment #3)
> On a side note: Is there currently any pref to disable and/or hide the display
> or collection of recently bookmarked or tagged items from the bookmarks menu?

set browser.places.smartBookmarksVersion to -1
oh, and delete those smart bookmarks (Recent Tags and Recently Added), they won't be re-created

Updated

9 years ago
Duplicate of this bug: 475944

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 432019
Target Milestone: Firefox 3.1 → Firefox 3.5
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.