error while connection to postgres with BUGZILLA

RESOLVED INVALID

Status

()

Bugzilla
Installation & Upgrading
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: raj, Unassigned)

Tracking

3.0.4
x86
Windows XP

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: http://www.bugzilla.org/news/#release304

We have installed
bugzilla 3.0.4, 
Perl 5.10.0
Postgresql 8.3.1
DBD-pg v1.48

 We are following the Bugzilla Guide 3.0.3
 
Once this has been completed we need to configure with the Apache webserver
But when we run '/CHECKSETUP.PL' inside the bugzilla folder
We are getting this error 
   'Pg' is not a valid choice for $db_driver in localconfig: Unknown error Compilation failed in require at (eval 211) line 3, <DATA> line 225.

We have changed the DB_driver as 'Pg' in the localconfig files inside the bugzilla folder. 

Reproducible: Always

Steps to Reproduce:
1.Install the above comination 
2.Run the checksetup.pl
3.Get the error
Actual Results:  
getting error 
'Pg' is not a valid choice for $db_driver in  localconfig: Unknown error
Compilation failed in require at (eval 211) line 3, <DATA> line 225.

Expected Results:  
It should be connected to postgres with the bugizlla, because we get the message 
Checking for          DBD-Pg (v1.45)   ok: found v1.48

we have checked that the POSTGRES is running while we are connecting with Bugzilla.

WE are using a UNIX environment to connect this.

Comment 1

10 years ago
Not weave.
-> bugzilla
Assignee: nobody → installation
Component: Weave → Installation & Upgrading
Product: Mozilla Labs → Bugzilla
QA Contact: weave → default-qa
Target Milestone: -- → ---
Version: unspecified → 3.0.4

Comment 2

10 years ago
This sounds like a support issue, actually, not a bug in Bugzilla. Ask it on the bugzilla-support mailing list, described here:

  http://www.bugzilla.org/support/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.