Default font-style applies to text-paragraphs but not to tables and lists

RESOLVED DUPLICATE of bug 250539

Status

MailNews Core
Composition
--
enhancement
RESOLVED DUPLICATE of bug 250539
9 years ago
6 years ago

People

(Reporter: crimle, Unassigned)

Tracking

({fonts})

1.9.1 Branch
fonts

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Version 2.0.0.14 (20080421)

A mail that contains paragraphs with "normal text" AND a table AND a bulleted or numbered list will be displayed with different font-styles and different font-sizes dependent on the mail-client the receiver uses.

Reproducible: Always

Steps to Reproduce:
1. Let’s assume you defined “Trebuchet” as your default font-family
2. Create a new (HTML) mail
3. Enter a paragraph with normal text
4. Enter a table
5. Enter another paragraph with normal text
6. Enter a bulleted list
7. Enter another paragraph with normal text
8. Enter a numbered list
9. Enter another paragraph with normal text 
10. Send the mail and watch it with different mail-clients
Actual Results:  
1. Thunderbird: the mail looks very much the same as it was sent
2. Other mail-clients (Outlook, GMX Webmail, ...): the paragraphs with normal text look all right. But the text in the tables and the bulleted/numbered lists have a different font style and sometimes a different font-size, I guess it's "Times New Roman".

Expected Results:  
The defaults (font-style, font-size) a user defines in the settings should apply to the whole mail, not only to paragraphs. They should espescially apply to tables and lists. A clever solution would be a CSS-section within the <head> tag of the mail.

I analyzed the HTML-code produced by three different mail-clients:

1. GMX Webmail
adds some CSS-statements to the <head> section. The <font-family> tag for example is part of the <body> definition. GMX mails look handsome, a unique font-style and font-size throughout the whole mail. And from the technical point of view, the CSS approach is very elaborate (in my humble opinion).

2. Outlook
adds <font> tags to every single line. The result is handsome though, but it's a disaster from the technical point of view.

3. Thunderbird
produces clean HTML-code but avoids the CSS approach. Puts a <font> tag to paragraphs only but neither to tables nor to lists. The result is (as I mentioned above) a mail that is displayed with different font-styles even though the sender did not touch the font-style-buttons.
Component: Mail Window Front End → Message Compose Window
QA Contact: front-end → message-compose
(Reporter)

Updated

9 years ago
Keywords: fonts
Duplicate of this bug: 481141
Component: Message Compose Window → Composition
Product: Thunderbird → MailNews Core
QA Contact: message-compose → composition
Version: unspecified → 1.9.1 Branch
Bug 481141 is about tb 3.0b2.

Christof  could you add screenshot describing the issue, thank you.
(Reporter)

Comment 3

8 years ago
Created attachment 365153 [details]
Mail with text paragraph, bulleted list and table.

The behaviour between TB2 and TB3 is slightly different. 
-> With TB2 the sender does not see any font-style difference between the paragraphs. It is only the receiver who gets an "ugly" mail. 
-> With TB3 the sender can see the font changing as soon as he clicks the bulleted list button or inserts a table

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 250539
You need to log in before you can comment on or make changes to this bug.