onresize handler gets called on page load

RESOLVED INVALID

Status

()

Firefox
General
--
critical
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Kristian Jörg, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; sv-SE; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; sv-SE; rv:1.9) Gecko/2008051206 Firefox/3.0

I have a onresize handler on my webbpage that is supposed to reload the page so that my appet can be resized to properly fit the page.
This has worked fine in Firefox 2 and IE from version 5 and forward. However with version 3 RC1 (this is the only version 3 I have tested) the onresze handler gets called on the initial load - which will send the web page into an infinite loop.

This is very unfortunate and I regard it a bug. OnResize should not be called at any time until the page is fully loaded.

This web site demonstrates the problem: 
http://test.devo.se/temp_bv

Klick on one of the thumbnails to start a bookviewer. With older Firefox or IE - no problem. Firefox 3 = infinite loop.

This behaviour breaks the functionality of my web applications, i.e the bookviewer and related products.

Note, to test this you need to have the Java plugin installed as this is a java applet web page.

Reproducible: Always

Steps to Reproduce:
1. Enter the site http://test.devo.se/temp_bv
2. Klick on one of the thumbnails to start a bookviewer
Actual Results:  
The onresize handler gets called during the page loading, and since it reloads the page - the infinite loop is started.

Expected Results:  
The onresize handler should not be called until the user explicitly resizes the window.
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch
Testing Firefox 3.0 branch on Windows XP I see indeed a resize when the page is loading but no loop.
(In reply to comment #0)

> which will send the web page into an
> infinite loop.

(In reply to comment #1)
> Testing Firefox 3.0 branch on Windows XP I see indeed a resize when the page is
> loading but no loop.
>
With "loop" I meant something infinite (like reloading repeatedly) that you can't stop. The page seems to function normally here, except the resize of the page when it loads.  
(Reporter)

Comment 3

10 years ago
(In reply to comment #2)
> With "loop" I meant something infinite (like reloading repeatedly) that you
> can't stop. The page seems to function normally here, except the resize of the
> page when it loads.  
> 

I have finally found the reason to the problem. The plugin Forecastfox causes this problem. When that plugin is disabled the problem goes away. If the problem is due to a bug in Forecastfox or if it is something in Firefox 3 that causes it in combination with Forecastfox I do not know. That may need to be investigated...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.