Receiving an image/tiff which has been compressed with the Content-Encoding set to gzip, doesn't decompress before passing to plug-in viewer.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
3 years ago

People

(Reporter: remi, Unassigned)

Tracking

4.0 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008051202 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008051202 Firefox/3.0

In version v2 and v3 beta of firefox, when receiving an image/tiff document that has been gzipped for delivery to the browser, the quicktime plugin viewer fails to display the image/tiff document. Decompressing before sending the document to the browser works.

Reproducible: Always

Steps to Reproduce:
1. Using Firefox for Mac (v2 or v3)
2. GET image/tiff where the Content-Encoding is set with gzip
3. 
Actual Results:  
The quicktime plugin view displays a blank page.

Expected Results:  
the Quicktime plugin viewer should display the tiff image

I believe after the browser accepts the image/tiff and before passing the image/tiff document to the plugin, firefox needs to decompress the document before the plugin tries to display the image.
This is a mass search for bugs that are in the Firefox General component, are
UNCO, and have not been changed for 800 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10, create a fresh profile,
http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you
still see the bug, please update this bug. If the issue is gone, please set the
resolution to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
(Reporter)

Updated

8 years ago
Hardware: PowerPC → x86
Version: unspecified → 3.6 Branch
So Remi, do you still see this?
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> So Remi, do you still see this?

Yes the problem still exists. Would you like me to setup a test scenario? I've
worked around the problem by not sending image/tiff with Content-Encoding of
gzip by ignoring the Accept-Encoding. I figured there might be a under lying problem when passing content to the plugin handlers.
If you could set up a test environment for me I would appreciate it.
Whiteboard: [CLOSEME 2010-11-01]
(Reporter)

Comment 5

8 years ago
Here is the examples in html:
http://www.metrex.net:8080/test_tiff.html

The two test links are as follows:

A tiff file where the content encoding is gzipped:
http://www.metrex.net:8080/test-c.tiff

The same tiff file with no content encoding:
http://www.metrex.net:8080/test-nc.tiff

Note: if you do a "Save link as..." on the compress version firefox does save the file correctly. It just can't display it. Also Quicktime is necessary as it is the plugin that is used to display the tiff.
(Reporter)

Comment 6

8 years ago
duh, I changed the URL so that it works past our firewall. I apologize.

Here is the examples in html:
http://www.metrex.net/test_tiff.html

The two test links are as follows:

A tiff file where the content encoding is gzipped:
http://www.metrex.net/test-c.tiff

The same tiff file with no content encoding:
http://www.metrex.net/test-nc.tiff

Note: if you do a "Save link as..." on the compress version firefox does save
the file correctly. It just can't display it. Also Quicktime is necessary as it
is the plugin that is used to display the tiff.
Reporter, Firefox 4.0.1 has been released, and it features significant improvements over previous releases. Can you please update to Firefox 4.0.1 or later, and retest your bug? Please also create a fresh profile (
http://support.mozilla.com/kb/Managing+profiles), update your plugins (Flash, Java, Quicktime, Reader, etc) and update your graphics driver and Operating system to the latest versions available. 

If you still continue to see this issue, please comment. If you do not, please close this bug as RESOLVED > WORKSFORME

filter: prefirefox4uncobugs
(Reporter)

Updated

8 years ago
Version: 3.6 Branch → 4.0 Branch
(Reporter)

Comment 8

8 years ago
The problem exists in Firefox 4.0.1.

Comment 9

7 years ago
This sounds related to #559564.

Comment 10

3 years ago
The test cases aren't accessible any longer.
Is this issue still reproducible in the latest Firefox?

https://www.mozilla.org/de/firefox/new/
Flags: needinfo?(remi)
(Reporter)

Comment 11

3 years ago
I've made the test case available again.
However, it seems the support for viewing TIFFs via the QuickTime plugin has gone away, there maybe little point keeping this ticket around. Firefox 44.0.1 seems to just download the tiff files.

This problem just went away... :)
Flags: needinfo?(remi)

Comment 12

3 years ago
Okay, I'm closing this bug as WFM.

Thank you very much for your efforts :)

Jan
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.