something fishy in xpc_CloneJSFunction

RESOLVED DUPLICATE of bug 434673

Status

()

RESOLVED DUPLICATE of bug 434673
11 years ago
5 years ago

People

(Reporter: vlad, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

There are a bunch of crash reports in Socorro with xpc_CloneJSFunction as the second item in the stack, at http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/js/src/xpconnect/src/xpcwrappednativeinfo.cpp&rev=1.19&mark=76#76 .. the topmost is often JS_GetReservedSlot, but there are also a pile with bogus values at the top such as http://crash-stats.mozilla.com/report/index/f4120691-285e-11dd-9772-0013211cbf8a .  My guess is that 'scope' that's dereferenced just before line 76 is bogus, and that's where the actual problem is.

I can't get Socorro to successfully complete a query for xpc_CloneJSFunction using the nightly version as opposed to RC1, so I can't see if there's an obvious point where this started.  Filing this to track.

I've hit this very frequently myself, but using the Rhapsody plugin; my crashes look like http://crash-stats.mozilla.com/report/index/4353796e-2864-11dd-b3e3-001321b13766 (consistent from _geturl on down).

Updated

11 years ago
Whiteboard: DUPEME

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 434673

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.