compose command line command returns non-zero if thunderbird is running

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
10 years ago
8 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2010-12-01, URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: version 2.0.0.14 (20080421)

When executing thunderbird with the compose command, for example

thunderbird.exe -compose "to=name@domain.com"

the return code is different depending on whether thunderbird is already running in the background or not. It is 0 if thunderbird is not running, and 1 if it is running.

Non-zero return codes are used to indicate that the command failed - which is not the case here. 

For convenience, here is a batch file to easily reproduce this behaviour:

------8<-------8<-----
"C:\Program Files\Mozilla Thunderbird\thunderbird.exe" -compose "to=name@domain.com"
echo Error level is %errorlevel%
------8<-------8<-----


Reproducible: Always

Steps to Reproduce:
1. Start Thunderbird
2. Run  thunderbird.exe -compose "to=name@domain.com"  from command line
3. view errorlevel
Actual Results:  
Return code will be 1

Expected Results:  
Return code shall be 0, as no error occured

Comment 1

10 years ago
I'm sure this can be platform specific, but it works fine on linux/trunk.
(Reporter)

Comment 2

10 years ago
I've tested on Linux with 2.0.0.14 and it also works correctly there.
So the problem seems to be specific to the Win32 version of Thunderbird.
Version: unspecified → 2.0

Comment 3

10 years ago
I confirm TB 3.0b2pre returns 1. I can't find a description of the error codes. Do you have a reference?

I get 9009 when running the command and thunderbird is not running, which might also be a bug.

note, i think your command line syntax is slightly off. should be 
  to="address"  or    to=address

xref Mac Bug 469990 -compose does not work on Mac OS X when TB is already running

references:
 https://developer.mozilla.org/En/Command_Line_Options
 http://kb.mozillazine.org/Command_line_arguments_%28Thunderbird%29

Comment 4

10 years ago
my bad, I see -compose should take "to=blah"

Comment 5

8 years ago
(pinging bugs marked version 2.0)

Do you also see this problem in version 3.1? 
  http://getthunderbird.com/

If you do not, please close the bug with status set to RESOLVED and resolution set to WORKSFORME.
Whiteboard: closeme 2010-12-01
RESOLVED INCOMPLETE due to lack of response to previous comment. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.