Window freezes if drag-and-drop while cookie prompt is loaded

RESOLVED DUPLICATE of bug 424900

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 424900
10 years ago
10 years ago

People

(Reporter: John, Unassigned)

Tracking

3.0 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0

If you have Firefox 3.0 RC1 set to prompt each time a website tries to set a cookie, and you are dragging-and-dropping a tab or a bookmark at the *exact* time the cookie allow/deny dialog box appears, both the window you are dragging-and-dropping the bookmark/tab on, and the cookie prompt, will become 'frozen.' Specifically, neither will respond to any clicks, including the Close button, and right-clicking the window's tab in the Taskbar will not present a menu to close the window. Only terminating firefox.exe and relaunching will resolve the problem.

Reproducible: Always

Steps to Reproduce:
1.) Set Firefox 3.0 RC1 to prompt you every time a website tries to set a cookie.
2.) Visit a new website which sets cookies and you currently have no cookie acceptance policy for.
3.) Before the prompt to allow/deny the cookie appears, begin to drag-and-drop a tab or a bookmark. (Act quickly!)

ALTERNATIVELY:
1.) Set Firefox 3.0 RC1 to prompt you every time a website tries to set a cookie.
2.) Bookmark a website, leave the website, and then delete its cookie acceptance policy.
3.) Open Organize Bookmarks (Library).
4.) Begin to drag-and-drop the newly-created bookmark.
Actual Results:  
The respective windows/dialog boxes became 'frozen,' as if disabled or unfocusable.

Expected Results:  
Firefox 2.0.x handled this fairly well, automatically granting the cookie prompt focus, flashing the dialog box, and playing the system default sound.

Reproduced on three separate installations/machines, two of which had clean profiles with no extensions or themes installed.
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch
If you don't use microsummaries you could set browser.microsummary.enabled to false in about:config.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 424900
You need to log in before you can comment on or make changes to this bug.