Wrong thousand separator on mozilla addons site

VERIFIED DUPLICATE of bug 432847

Status

addons.mozilla.org Graveyard
Localization
--
trivial
VERIFIED DUPLICATE of bug 432847
10 years ago
2 years ago

People

(Reporter: Kamil Páral, Unassigned)

Tracking

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; cs-CZ; rv:1.9b5) Gecko/2008050509 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; cs-CZ; rv:1.9b5) Gecko/2008050509 Firefox/3.0b5

On mozilla addons site, there is download count for each of the addon. In czech localization the separator is not showing correctly, there is only "unknown sign" (question mark). See the attached screenshot (it's highlighted in orange ellipse). I'm using Ubuntu 8.04 and FF 3 Beta 5 (default from repositories). Maybe the localization was created using wrong character encoding.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.


Expected Results:  
There should be a space as a thousands separator, which is correct for Czech language. Certainly not this unknown sign.
(Reporter)

Comment 1

10 years ago
Created attachment 322423 [details]
wrong thousand separator
Status: UNCONFIRMED → NEW
Ever confirmed: true
The thousands separator is pull out from the PHP localeconv() function and it was introduced in bug 419639. The sk locale has the same problem.

Assignee: p.franc → fligtar

Updated

10 years ago
Assignee: fligtar → nobody
Component: cs / Czech → Localization
Product: Mozilla Localizations → addons.mozilla.org
QA Contact: aha → l10n
Created attachment 334383 [details]
looks alright to me

Attaching what it looks like for me - essentially just a space.  It looks like it's printing a character that's not available in your charset or something?  Have either of you experienced this before?

Comment 4

10 years ago
Yes, this is/was bug 432847. It's a special "UTF-8 space" character.

It wfm too.
Depends on: 432847

Comment 5

10 years ago
Does changing your default font resolve the problem? Maybe it doesn't support the character correctly. (A workaround on our side would certainly be replacing this by an actual space, but this may defeat almost the purpose of using localeconv() in the first place).
(Reporter)

Comment 6

10 years ago
Created attachment 334421 [details]
new page look

The page has changed, it looks a little different now. It seems to be fixed. I can't test what was the problem though. But the source of the these kind of problems is very often that people on Windows have default charset set to Windows-xxxx, but people on Linux have default charset set to UTF-8.
stephend: can you give us a look from a windows box?
Created attachment 334425 [details]
Screenshot of Windows XP / Firefox 3.01

I just see a space character too...
Thanks Stephen.  I guess we fixed this with another bug sometime.  If anyone sees it reappear feel free to reopen.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(In reply to comment #9)
> Thanks Stephen.  I guess we fixed this with another bug sometime.

Argh, I didn't realize the bug was so old. In that case, of course it's a dupe of bug 432847, as I said in comment 4.
Resolution: FIXED → DUPLICATE
Duplicate of bug: 432847
Verified dup
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.