XHTML frames Page content vanishes

RESOLVED WORKSFORME

Status

()

Core
XML
P2
major
RESOLVED WORKSFORME
18 years ago
3 years ago

People

(Reporter: Ronald Buckman, Assigned: Nisheeth Ranjan)

Tracking

({xhtml})

Trunk
x86
Windows 98
xhtml
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-], URL)

Attachments

(1 attachment)

717 bytes, application/octet-stream
Details
(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m17) Gecko/20000622
BuildID:    2000062210

The content of this XHTML page with two frames should remain on the page.  On
Mozilla it appears for a second and then disappears leaving the user with a
blank, light blue screen.  The content remains on the page in build M15,
Netscape Preview Release 1, and Netscape 4.08 .

Reproducible: Always
Steps to Reproduce:
1. Enter www.premierbotanicals.com/index.htm in the URL window.
2. Click the back button.
3. Click the forward button.

Actual Results:  One frame appeared than disappeared, the other frame appeared
than disappeared. When I returned back to the site, both frames appeared, than
disappeared.

Expected Results:  Kept displayed information on the screen.

This site has a left frame which contains the menu and a main frame.  Both
frames use external Cascading Style Sheets.  They use default external style
sheets, and style sheets accessed by javascripts, which are limited to certain
browser rendering engines.

Comment 1

18 years ago
frame content is overwritten with generated html. (i include a testcase)

testcase works correctly whein i remove those lines from home.htm

<?xml version="1.0"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    "http://www.w3.org/TR/xhtml1/DTD/transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">

component could be javascript or parser

script is loaded via <script type="text/javascript" src="alert.js"></script>

and in the script i've used document.write

Tested with BuildID 2000062220 on WinNT 
Status: UNCONFIRMED → NEW
Component: XML → Javascript Engine
Ever confirmed: true

Comment 2

18 years ago
Created attachment 10566 [details]
Testcase in a Zipfile
(Assignee)

Comment 3

18 years ago
Marking nsbeta3...
Status: NEW → ASSIGNED
Target Milestone: --- → M18
(Assignee)

Updated

18 years ago
Keywords: nsbeta3

Comment 4

18 years ago
this also happens on url: http://richinstyle.com
it also uses an external script with document.write.
this page doesn´t use frames, doctype is :

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0//EN" "http://www.w3.org/TR/REC-
html40/strict.dtd"> 

Comment 5

18 years ago
*** Bug 44565 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
*** Bug 45121 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
Also happens with this doctype:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"
"http://www.w3.org/TR/REC-html40/loose.dtd">

All pages rendered in standard mode have this problem...

Comment 9

18 years ago
Here is selected code from some offending site pages.  If there is a common
factor between them, I have missed it so far.  Only one is XML.


Page reported under bug 45121:
http://www.inxight.com/demos/ht_walk_thru/ht_walk_thru_02.html

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"
"http://www.w3.org/TR/REC-html40/loose.dtd"
<html>
<script type="text/JavaScript" language="JavaScript" src="/scripts/script_lib2.js">

This page behaves differently each time it is accessed under build 2000071108.
In general, the page is displayed longer than under build 200071020, which
behaved the same each time the page was accessed.



Page reported under bug 44565:
http://www.richinstyle.com/bugs

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0//EN"
"http://www.w3.org/TR/REC-html40/strict.dtd">

<html>
<style type="text/css">
<link rel="stylesheet" href="/style/all.css" type="text/css">
<script language="javascript1.2" src="/style/style.js" type="text/javascript">



Page reported under bug 43570:
http://www.premierbotanicals.com/index.htm

<?xml version="1.0"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Frameset//EN"
	"DTD/xhtml1-frameset.dta">
<html xmlns="http://www.w3.org/1999/xhtml=" xml:lang="en" lang="en">
<meta content="MSHTML 5.00.3018.900" name="GENERATOR" />
<frameset ...

(Don't see any javascript references on this one)



Page reported by R. K. Aa:
http://www.dagbladet.no/

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"
"http://www.w3.org/TR/REC-html40/loose.dtd">
<html>
<STYLE type="text/css">
<href="/cgi-bin/go3/go.cgi?http://www.start.no/&f=Start.no&t=Start">
<!--http://www.dagbladet.no/cgi-bin/go3/go.cgi?&f=dbforside&t=Drapssiktede+gutter+landet+i+Troms%F8-->


(Don't see any javascript references on this one, either)



Page reported by R. K. Aa:
http://www.cybercity.no/

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"
"http://www.w3.org/TR/REC-html40/loose.dtd">
<html>
<link rel="stylesheet" href="/lib/ns_style.css">
<!-- <a href="/produkter/onlinereg/"><img border="0" src="/banner/img/anim.gif"
width="410" height="60" alt="banner"></a><br> --><script CHARSET="ISO-8859-1"
TYPE="text/javascript" src="http://banner.cybercity.dk/phpAds/js.php3?clientID=2">

(Don't see any javascript references on this one, either)?

Comment 10

18 years ago
Here is selected code from some offending site pages.

Four of these pages are coded vs. HTML 4.0, the fifth vs. XHTML 1.0.  Use of
cutting-edge specifications is the only common factor I see (so far) with these
pages.


Page reported under bug 45121:
http://www.inxight.com/demos/ht_walk_thru/ht_walk_thru_02.html


<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"
"http://www.w3.org/TR/REC-html40/loose.dtd"

<html>
<script type="text/JavaScript" language="JavaScript"
src="/scripts/script_lib2.js">

This page behaves differently each time it is accessed under build
2000071108.  In general, the page is displayed longer than under build
200071020, which behaved the same each time the page was accessed.



Page reported under bug 44565:
http://www.richinstyle.com/bugs

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0//EN"
"http://www.w3.org/TR/REC-html40/strict.dtd">

<html>
<style type="text/css">
<link rel="stylesheet" href="/style/all.css" type="text/css">
<script language="javascript1.2" src="/style/style.js"
type="text/javascript">



Page reported under bug 43570:
http://www.premierbotanicals.com/index.htm

<?xml version="1.0"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Frameset//EN"
        "DTD/xhtml1-frameset.dta">
<html xmlns="http://www.w3.org/1999/xhtml=" xml:lang="en" lang="en">
<meta content="MSHTML 5.00.3018.900" name="GENERATOR" />
<frameset ...




Page reported by R. K. Aa:
http://www.dagbladet.no/

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"
"http://www.w3.org/TR/REC-html40/loose.dtd">
<html>
<STYLE type="text/css">
<href="/cgi-bin/go3/go.cgi?http://www.start.no/&f=Start.no&t=Start">
<!--http://www.dagbladet.no/cgi-bin/go3/go.cgi?&f=dbforside&t=Drapssikt
ede+gutter+landet+i+Troms%F8-->




Page reported by R. K. Aa:
http://www.cybercity.no/

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"
"http://www.w3.org/TR/REC-html40/loose.dtd">
<html>
<link rel="stylesheet" href="/lib/ns_style.css">
<!-- <a href="/produkter/onlinereg/"><img border="0"
src="/banner/img/anim.gif" width="410" height="60" alt="banner"></a><br>
--><script CHARSET="ISO-8859-1" TYPE="text/javascript"
src="http://banner.cybercity.dk/phpAds/js.php3?clientID=2">

Comment 11

18 years ago
summary description is not absolutly clear

All pages using external scripts with document.write will be overwritten with 
generated html. All pages rendered in standard mode(forced via DOCTYPE) have 
this problem.

http://www.premierbotanicals.com/index.htm
  -> is the frameset -> there is no script but in the two frames there is one.
 

http://www.cybercity.no 
  is also a duplicate of this bug it uses an external script loaded from
 http://banner.cybercity.dk/phpAds/js.php3?clientID=2

--> 
http://www.dagbladet.no/ 
 is a seperate bug! it uses a script(not external) with document.open() and 
this clears the window. i don´t know if this is already reported.

Comment 12

18 years ago
sorry. www.dagbladet.no is bug 43741

Comment 13

18 years ago
*** Bug 44815 has been marked as a duplicate of this bug. ***

Comment 14

18 years ago
*** Bug 47165 has been marked as a duplicate of this bug. ***

Comment 15

18 years ago
This is actually a DUPL 29135, as are a slew of others.
Somebody process..
JavaScript is not the issue, the component should be Layout
Also, the OS should be All

Comment 16

18 years ago
Sorry for the typo; should be DUPL 29125

Comment 17

18 years ago
Sorry Aaron, this is not a dup of 29125
, this is a javascript issue.
(Assignee)

Comment 18

18 years ago
Given that this happens on many pages, marking nsbeta3+
Whiteboard: [nsbeta3+]
(Assignee)

Updated

18 years ago
Keywords: xhtml
(Assignee)

Comment 19

18 years ago
Marking P2...
Priority: P3 → P2
(Assignee)

Comment 20

18 years ago
This bug seems to have been fixed because we no longer use the strict dtd.  
Putting on the nsbeta3- radar for now and requesting qa help.  Please renominate 
this for beta 3 if you find that many pages are showing up blank.  Thanks.

Specifically, I went to http://www.premierbotanicals.com/index.htm and 
http://richinstyle.com using today's NT debug build.  Both pages displayed 
properly.
Keywords: qawanted
Whiteboard: [nsbeta3+] → [nsbeta3-]

Comment 21

18 years ago
this one seems to be fixed. not reproduceable anymore on win9x,nt with buildid 
2000082815. testcase works also correctly (strict mode).

Comment 22

18 years ago
The problem continues to happen with M18 and nightly build 20000908. Not on the
other web sites mentioned in this bug report, but at least in
<http://clam.rutgers.edu/~ahagen/>, which contains some javascript. Compare the
same site on M15 or other browsers.

Comment 23

18 years ago
Andrew: your url has nothing to do with this bug report. content is missing on 
your pages (e.g. the images in http://clam.rutgers.edu/~ahagen/menu.xht)
content does not disappear due your javascript. content disappear because 
mozilla renders XHTML 1.0 Transitional//EN like HTML 4.0 Strict//EN and this 
seems to be a sperate bug. i don´t know if it has already been reported.
i´m look if it has already been reported if not i´m file a new bug report.

Comment 24

18 years ago
andrew: see bug 48617

Comment 25

18 years ago
I changed the site <http://clam.rutgers.edu/~ahagen/> to be fully compliant with
XHTML 1.0, and am testing with Mozilla M18 nightly build 20000911, but the
content still disappears from both frames. Compare the smae site on IE 5.5.

The frameset file is <http://clam.rutgers.edu/~ahagen/index.html> which is using
the DTD XHTML 1.0 Frameset//EN. The other two, main.xht and menu.xht, use XHTML
1.0 Transitional//EN as the DTD. All 3 files validate with "no errors found" on
<http://validator.w3c.org/> as valid XHTML 1.0.

There are no "--" character sequences in the three files, and no comments or
remarks.

I tried removing the Javascript, but it made no difference.

Thanks for your help.

Comment 26

18 years ago
andrew: 
do you mean the complete content disappears from both frames ? (which os are 
you using ?)
or do you mean parts of the content disappear ? (if only parts disappear see 
bug 48617, a workaround would be, to but a <p> tag around your missing images 
or links.)

Comment 27

18 years ago
I've been having problems for several weeks now.  My site used to be displayed
without any problems.  At some point, it appears that something got changed.
URL: http://www.aceprogrammer.com/
Expected result: A window with two frames (right/left).
Actual result: A blank window.

I've validated not only the main frames file (index.html), but both files used
as sources (toc.shtml and details.shtml) using http://validator.w3.org/

I can display toc.shtml or details.shtml in a window by themselves.

Comment 28

18 years ago
ace: hmm...
this is a very funny one. in your frameset (in the head), you use something 
like this:

   <link rel="StyleSheet" href="style.css" type="text/css" media="screen" />

when you remove this line of code, frames are fully visible...
this might be a new bug...

Comment 29

18 years ago
Horwath Martin:
Thanks! Adding the <p> tags did it! I'll make sure the rest of my pages have <p>
tags, too. Take care.

Comment 30

18 years ago
Setting default component; current component (JS Engine) is not correct -
Component: Javascript Engine → XML

Comment 31

18 years ago
Checked with Mac OS 9.0.4, Mozilla build 2000100720-M18.

Both http://www.premierbotanicals.com/index.htm and
http://www.aceprogrammer.com/ worked fine.  No problems.

Comment 32

18 years ago
All testcases and urls work correctly. Also www.aceprogrammer.com content does 
not disappear anymore due fixed bug 48351.
We should mark this bug as fixed or worksforme

Comment 33

17 years ago
Since all the testcases work fine for me using build 2000122320 win32 and given
the last comment from Martin, and also since no attention has been given to this
bug in two months, I am marking this worksforme. Please reopen if it appears
that this is not fixed.
Fabian.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Updated

15 years ago
QA Contact: petersen → rakeshmishra
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.