selecting select1-list inside xforms:case (by using xforms:toggle inside a xforms:trigger) creates heavy cpu load and causes severe slow down of xforms page

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
11 years ago
2 years ago

People

(Reporter: kullmann, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla XForms 0.8.5

Creating a select1-element inside a xforms:switch -> xforms:case and selecting it by using a tab-like structure that uses xforms:trigger-elements slows down display of this case considerably and makes the use of xforms impossible for lists that have 200 or more entries. Using a instance with about 1000 entries, it takes about 2-3 minutes on a P4 3.2 GHz to render the xforms:select1. This does not happen on the initial xforms:case ("first tab"), only when selecting another one.

Reproducible: Always

Steps to Reproduce:
1. create instance with at least 200-300 entries
2. create two xforms:trigger elements that each contain a xforms:toggle ("two tabs")
3. create a xforms:switch 
4. create two xforms:case with unique ids
5. load xforms-file and select second toggle-element
Actual Results:  
When selecting the second tab, the cpu load will go up to 100% and, depending on the number of elements that are to be displayed in the select1-list, it may take up to minutes to actually display the list.

Expected Results:  
Render the list as for the first "tab", just taking less than a second to display.
(Reporter)

Comment 1

11 years ago
Created attachment 322487 [details]
demo with two tabs that each contain a select1-list with 200 entries

testcase to see the cpu load and slow down of display when selecting "Second" tab

Comment 2

9 years ago
The same type of sample , tested with 300 records with data window option .. the loading time of the sample is more better then your case like whole data file will load at the same time. and move from one record to another also flexible ...

Comment 3

9 years ago
But not in select1 control ,, like in that kind of sample used XQuery to load the xml file ,, it's more faster then the normal load from direct xml file

Comment 4

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.4) Gecko/20100503 Firefox/3.6.4

Can't reproduce given test case on Firefox 3.6.4. I got the following error:

"XML Parsing Error: not well-formed
Location: https://bug435716.bugzilla.mozilla.org/attachment.cgi?id=322487
Line Number 17, Column 79: [...]"

Comment 5

9 years ago
Created attachment 444271 [details]
Testcase v2

Comment 6

9 years ago
To get example working I removed calls of instance function from xf:bind. I don't understand why it doesn't work with instance function. 

Now when selecting the second tab I get the following:

uncaught exception: [Exception... "Illegal operation on WrappedNative prototype object"  nsresult: "0x8057000c (NS_ERROR_XPC_BAD_OP_ON_WN_PROTO)"  location: "JS frame :: chrome://xforms/content/xforms.xml :: focus :: line 469"  data: no]
RIP xforms
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.