Display Keywords in bookmark menu, where usually keyboard shortcuts are shown

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED WONTFIX
10 years ago
6 years ago

People

(Reporter: Jakub 'Livio' Rusinek, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

16.30 KB, image/png
Details
(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.9pre) Gecko/2008052604 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.9pre) Gecko/2008052604 Minefield/3.0pre

all menu items which have keyboard shortcut have it displayed at right side.

same should be done for bookmarks' keywords.

Reproducible: Always

Actual Results:  
no keywords in menu

Expected Results:  
all menu items which have keyboard shortcut have it displayed at right side.

same should be done for bookmarks' keywords.

example:

| Add bookmark         Control + D
| (...)
| The Coding Studio            tcs

Updated

10 years ago
Version: unspecified → Trunk
This could take space to bookmark names, or make the bookmark items too large.

Anyway it seems to me there's an extension that do this.

Comment 2

10 years ago
All the menu items have keyboard shortcuts by them, marking as resolved INVAILD.

I am using the latest build, not sure if yours has it, but it is certainly fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

10 years ago
I'm not using Trunk, but Stable.

Comment 4

10 years ago
Created attachment 330350 [details]
Edit menu

They are also in Firefox 3.0, see screenshot.
(Reporter)

Comment 5

10 years ago
I think you can't read...

This bug is about "bookmarks keywords" in "bookmarks menu", so why you're talking to me about keyboard shortcuts and marking this bug as invalid?
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 6

10 years ago
Created attachment 330351 [details]
Bookmark menu.

Sorry I took the wrong menu, is this what you are talking about? Sorry if I misunderstood.
Attachment #330350 - Attachment is obsolete: true
(Reporter)

Comment 7

10 years ago
OMG... Set some bookmark a keyword and then open menu to check if keyword is displayed in menu.

If yes, mark this as INVALID or FIXED (since it didn't featured in Firefox 3).
If no, don't come back...

Comment 8

10 years ago
myles7897, see the example in comment #0.

A bookmark keyword is a word that lets you, for example, use multiple search engines through the location bar.
It seems there's no duplicate. Confirmed as valid new bug, moving to Places (bookmarks+history) component - Bookmark is the old 2.0 component.
Status: UNCONFIRMED → NEW
Component: Bookmarks → Places
Ever confirmed: true
Keywords: uiwanted
OS: Linux → All
QA Contact: bookmarks → places
Hardware: PC → All
Summary: bookmarks menu: display bookmarks keyword where usually keyboard shortcut is shown → Display Keywords in bookmark menu, where usually keyboard shortcuts are shown
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
Thanks for catching this.
From the design & UX perspective, I don't think this problem can be fixed. 
First, showing the keywords in the bookmark menu will take a lot of space. Having the expanding arrow and keywords at the same time will make the UI over cluttered. 

Second, this does stay consistent with the system UI. Currently the space on the right side of menu is for keyboard shortcuts and expanding arrows. Putting keywords on that will break the consistency.

Last but not least, we realize the current bookmark manager on FX has a lot of space to be improved. Though improving bookmarks is not the priority list for now, the UX team will keep our thoughts on this.
Status: NEW → RESOLVED
Last Resolved: 10 years ago6 years ago
Keywords: uiwanted
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.