Unexpected installation error returned when installing certain add-ons

RESOLVED DUPLICATE of bug 430579

Status

()

Toolkit
Add-ons Manager
RESOLVED DUPLICATE of bug 430579
10 years ago
10 years ago

People

(Reporter: Liam K., Unassigned)

Tracking

1.9.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0

When I try installing certain add-ons such as Session Manager and Prism for Firefox, I get an error that says

"Firefox could not install the file at [url]

because: Unexpected installation error
Review the Error Console log for more details.
-203"

If I try again, Firefox says that the extension is incompatible with my version of Firefox, and a force install returns the same error again.

Looking at the Error Console, it says:

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsISafeOutputStream.finish]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Firefox%203%20Beta%202/components/nsExtensionManager.js :: closeSafeFileOutputStream :: line 508"  data: no]
Source File: file:///C:/Program%20Files/Mozilla%20Firefox%203%20Beta%202/components/nsExtensionManager.js
Line: 508

There are also similar errors.

Reproducible: Sometimes

Steps to Reproduce:
1. Attempt to install an extension such as Session Manager or Prism for Firefox.
Actual Results:  
I get an error.

Expected Results:  
The add-on should be installed succesfully.

Add-ons that have been successfully installed:

Adblock Plus 0.7.5.4
Java Console 6.0.05
Nightly Tester Tools 2.0.2
Web Developer 1.1.6

Build ID: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0 ID:2008051206
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch
(Reporter)

Comment 1

10 years ago
An additional error found in my console is this, I'm not sure it is related:

Error: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIDOMHTMLTableSectionElement.appendChild]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: https://bugzilla.mozilla.org/js/sorttable.js :: anonymous :: line 50"  data: no]
Source File: https://bugzilla.mozilla.org/js/sorttable.js
Line: 50
(Reporter)

Updated

10 years ago
Flags: blocking-firefox3?
Dave: is this a dupe?
Liam, do you have any anti-virus or malware scanning software on your machine?
Component: Extension Compatibility → Extension/Theme Manager
QA Contact: extension.compatibility → extension.manager
Dave, clearing blocking flag until we can get a confirmation, please renom if this is a serious non-dupe issue.
Flags: blocking-firefox3?
(Reporter)

Comment 5

10 years ago
(In reply to comment #3)
> Liam, do you have any anti-virus or malware scanning software on your machine?
> 

Yes, I'm running WinPatrol, Mamutu, ThreatFire, Avira Antivir, SpywareGuard, and Windows Defender.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 430579
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.