If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Explain users NOT to use ScriptAlias directive when configuring bugzilla as CGI

RESOLVED WORKSFORME

Status

()

Bugzilla
Documentation
--
trivial
RESOLVED WORKSFORME
9 years ago
4 years ago

People

(Reporter: Martin Mokrejs, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.13) Gecko/20080520 SeaMonkey/1.1.9
Build Identifier: 

In the installation documentation you have the following code:

    <Directory /var/www/html/bugzilla>
    AddHandler cgi-script .cgi
    Options +Indexes +ExecCGI
    DirectoryIndex index.cgi
    AllowOverride Limit
    </Directory>

Unfortunately, it is not clear that a user may not prepend in front of it
ScriptAlias directive otherwise .css files get attempted to be executed as CGI scripts by Apache. Please, save me few hours for the next time and put into the code like there the following lines or similar:

# Alias /bugzilla/  /var/www/html/bugzilla/
# do not ever use ScriptAlias because the .css files need to be sent
# to the client and not executed on the server

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
https://bugzilla.readthedocs.org/en/latest/installation.html has a caution about using ScriptAlias.

Gerv
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Comment hidden (spam)

Comment 3

4 years ago
mikedoak: Please stop spamming random bug reports with unhelpful comments, otherwise your account will get disabled.
You need to log in before you can comment on or make changes to this bug.