Custom global shortcuts for "Window > Zoom" in Mac OS X do not work correctly since Firefox 3 RC1, unless menu is opened. If menu is opened, new shortcut invokes <menuitem command"..."> as expected.

RESOLVED DUPLICATE of bug 429824

Status

()

Core
Widget: Cocoa
RESOLVED DUPLICATE of bug 429824
10 years ago
a year ago

People

(Reporter: Titus Stevenson, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008052604 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008052604 Minefield/3.0pre

Using System Preferences I have set a global shortcut for the Zoom functionality in the Window menu (Ctrl+Cmd+W). With the beta versions of Firefox 3 you could use the shortcut to zoom a window as expected. Since RC1 (including all nightly builds) the shortcut does not work anymore with Firefox, while it still works flawlessly with all other applications.

Reproducible: Always

Steps to Reproduce:
1.In System Preferences, set global shortcut for "Zoom" to Ctrl+Cmd+W
2.Have a firefox window open
3.Press the shortcut. Nothing happens.
Actual Results:  
Window is not zoomed.

Expected Results:  
Window should be zoomed

If you have the Window menu open and then press the shortcut it does actually work.

If you have opened the Window menu previously it gets highlighted when pressing the shortcut but nothing happens.
Confirming. I see this using  Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008053008 Firefox/3.0. It works using Safari. When I issue the command with Firefox all that happens is that the menu items flashes.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 436712
Duplicate of this bug: 434477
If this worked in the betas then it is a regression. Need to go back and check earlier builds. Reporter: Which beta version do you remember it working in?
Using the latest nightly Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a1pre) Gecko/2008053102 Minefield/3.1a1pre, I don't even get a flash in the menu when I issue the global command.
(Reporter)

Comment 6

10 years ago
(In reply to comment #4)
> If this worked in the betas then it is a regression. Need to go back and check
> earlier builds. Reporter: Which beta version do you remember it working in?
> 

In beta 4 the shortcut works but only after having opened the Window menu once "by hand". If you don't do that it will just issue an error sound.
Assignee: nobody → joshmoz
Component: OS Integration → Widget: Cocoa
Product: Firefox → Core
QA Contact: os.integration → cocoa
Version: unspecified → Trunk
Josh, Masayuki:

These bugs are a consequence of the recent key handling changes,
right?

In any case they regressed starting with the 2008-04-08-04-trunk
nightly, after the patch for bug 398514 landed.

Comment 8

10 years ago
Is this same as Bug 429824?
> Is this same as Bug 429824?

Yes, I think it is.

(In fact I half-remembered that bug and was looking for it earlier
... but couldn't find it.)
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429824
Temporarily re-open for comparison with Bug 827652.
    Bug 435863 : oldest   report after bug 429824(for Firefox 3 RC1), and for ZOOM(no predefined shortcut) case.
    Bug 827652 : newest report after bug 429824(for Fireox 17),        and for ZOOM(no predefined shortcut) case.
Blocks: 1015670
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Oh, bug 434477 and bug 436712 was duped to bug, eve tough this bug was duped to other bug...
Duping these two bugs to bug 429824 for ease of tracking.
Summary: Custom global shortcuts in Mac OS X do not work correctly with Firefox → Custom global shortcuts for Window > Zoom in Mac OS X do not work correctly since Firefox 3 RC1
Summary: Custom global shortcuts for Window > Zoom in Mac OS X do not work correctly since Firefox 3 RC1 → Custom global shortcuts for "Window > Zoom" in Mac OS X do not work correctly since Firefox 3 RC1, unless menu is opened. If menu is opened, new shortcut invokes <menuitem command"..."> as expected.

Updated

4 years ago
Assignee: joshmoz → nobody
Status: REOPENED → RESOLVED
Last Resolved: 10 years agoa year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429824
You need to log in before you can comment on or make changes to this bug.