Weave is set to Manual Connect but still periodically prompts for the Master Password

RESOLVED DUPLICATE of bug 410550

Status

RESOLVED DUPLICATE of bug 410550
11 years ago
10 years ago

People

(Reporter: lvb2k2, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0
Build Identifier: 0.130

I have weave synchronize with the server in a manual-basis. 

In my weave Sign In dialog, "Automatically connect each time I start firefox" is disabled.

Then, when I want weave to synchronize, I left-click on the status icon and select sign-in; I get prompted my Master Password, and then everything goes on as it should.

This use case worked great until last week. After the update to 0.1.30, with all my same settings as before, weave periodically triggers firefox to ask me my "Master Password", which is annoying. I know it is weave triggering the request, because I can see it in weave's log.

Weave should not be periodically triggering a connection to the server (and thus a password prompt) unless I set it up to automatically connect. 

Please go back to the <= 0.1.29 behaviour. This happens both under Windows (RC1) and Linux (3b5).


This is an extract of the log:


2008-05-26 23:44:21	Service.Main	INFO	Weave scheduler enabled
2008-05-27 00:14:21	Service.Main	INFO	Running scheduled sync
2008-05-27 00:14:25	Async.Generator	ERROR	Exception: [Exception... "'User canceled Master Password entry' when calling method: [nsILoginManagerStorage::findLogins]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Firefox%203%20Beta%205/components/nsLoginManager.js :: anonymous :: line 465"  data: no]
2008-05-27 00:44:25	Service.Main	INFO	Running scheduled sync
2008-05-27 00:44:28	Async.Generator	ERROR	Exception: [Exception... "'User canceled Master Password entry' when calling method: [nsILoginManagerStorage::findLogins]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Firefox%203%20Beta%205/components/nsLoginManager.js :: anonymous :: line 465"  data: no]
2008-05-27 01:14:32	Service.Main	INFO	Running scheduled sync
2008-05-27 01:14:41	Async.Generator	ERROR	Exception: [Exception... "'User canceled Master Password entry' when calling method: [nsILoginManagerStorage::findLogins]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Firefox%203%20Beta%205/components/nsLoginManager.js :: anonymous :: line 465"  data: no]
2008-05-27 01:44:41	Service.Main	INFO	Running scheduled sync
2008-05-27 01:44:44	Async.Generator	ERROR	Exception: [Exception... "'User canceled Master Password entry' when calling method: [nsILoginManagerStorage::findLogins]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Firefox%203%20Beta%205/components/nsLoginManager.js :: anonymous :: line 465"  data: no]
2008-05-27 10:40:28	Service.Main	INFO	Running scheduled sync
2008-05-27 10:41:22	Async.Generator	ERROR	Exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIXMLHttpRequest.open]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/Chapu/Application%20Data/Mozilla/Firefox/Profiles/76tl0jpt.default/extensions/%7B340c2bbc-ce74-4362-90b5-7c26312808ef%7D/modules/dav.js :: DC__makeRequest :: line 133"  data: no]




Reproducible: Always

Steps to Reproduce:
1.install weave
2.in the sign in dialog, uncheck "automatically connect each time I start firefox"
3.restart firefox and wait a bit; sometimes the prompt shows up a few seconds after restart; check weave's logs to verify it is the culprit
Actual Results:  
I am getting unsolicited master password prompts

Expected Results:  
No prompts, unless I manually tell weave to Sign In

Seems to affect all platforms (verified in WinXP / RC1, and Linux U 8.04 / 3b5)

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 410550

Updated

10 years ago
Component: Weave → General
Product: Mozilla Labs → Weave
Target Milestone: -- → ---

Updated

10 years ago
Component: Weave → General
Product: Mozilla Labs → Weave
Target Milestone: -- → ---
QA Contact: weave → general
You need to log in before you can comment on or make changes to this bug.