[Trunk] Concurrent events get wrong widths in Week view

RESOLVED WORKSFORME

Status

Calendar
Calendar Views
--
major
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Ben Lerner, Unassigned)

Tracking

Trunk
x86
Windows XP

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008052606 Minefield/3.0pre
Build Identifier: TB 2008052703, Lightning nightly 2008052620, GData same nightly

I have two events in my calendar that both happen at 10:30--11:30.  In TB 2.0 with today's Lightning, the two events are the same width, i.e. half the width of each day in the week view.  In TB 3.0 with today's Lightning, the first event is just a few px wide, and the other takes up all the space.

See the attached picture

Reproducible: Always
(Reporter)

Comment 1

10 years ago
Created attachment 322686 [details]
screenshot of TB2.0 and TB3.0 on the same two events
Summary: Concurrent events get wrong widths in Week view → [Trunk] Concurrent events get wrong widths in Week view
Version: unspecified → Trunk
Are the events in different calendars? What type of calendars? What timezones are the events in? Could you copy the two events in question and paste them here? I can't reproduce using storage and ics calendar with Lightning 0.6a1 (2008052713) + 3.0a2pre Thunderbird (2008052703).
(Reporter)

Comment 3

10 years ago
Good points...  They are in two GData calendars, and I'm using the latest GData nightly.  (I don't want to post the URLs to them here, but I'll describe the entire events.)

In my profile in order, I have:
* 1 local calendar
* 5 locked remote ics calendars
* 6 editable GData calendars

1) In calendar 8 (i.e. the second editable GData calendar of 6), a repeating event every MWF, from 10:30-11:30 AM, Pacific time (GMT-8:00), from 3/31/08-6/6/08.  No reminder is set.

2) In calendar 10 (i.e. the fourth editable GData calendar of 6), a single event on Wednesday, 5/28/08, from 10:30-11:30 AM Pacific time, with a reminder 5 minutes before.

In that same profile, I tried creating a third event at the same time (i.e., same data as event #1) in my local calendar.  I then tried showing just two out of the three calendars (local, GData 2 and GData 4), all three, and just one at a time.  Results:

* With each calendar on its own, the event is of full width.
* With GData 2 and GData 4, the results are as in the first screenshot above.
* With Local and GData 2, the results are the same (just with different colors for the local calendar)
* With Local and GData 4, *the two events are of equal width* (?!?)
* With all three calendars shown, the results are in the second screenshot above.

I haven't done anything odd to these calendars, and I'm pretty sure these events displayed correctly with yesterday's nightlies.  This may be a regression, but without reinstalling yesterday's versions I can't be sure right now...
(Reporter)

Comment 4

10 years ago
Created attachment 322698 [details]
when all three calendars are shown at once...
(Reporter)

Comment 5

10 years ago
I just noticed: the version of Lightning installed in TB2.0 is build 2008052704 (claiming to be 0.9pre), while the version in TB3.0 is build 2008052620 (claiming to be 0.6a1).  Both of these were obtained with the Lightning Nightly Updater, and both claim they're the most recent builds available.  So I may not be comparing the same two pieces of code...
(Reporter)

Comment 6

10 years ago
Hmmm...with today's latest nightly -- TB version 3.0a2pre 2008060303, Lightning build 2008060318, GData to match -- this problem seems to be gone.  Not sure what changed, but I'm glad it did :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.